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1

Introduction to the manual

Contents of this chapter
This chapter contains information on the applicability, compatibility, target audience and 
the purpose of the manual. It also describes the contents of the manual.

See topics:
Purpose of the manual  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15
Applicability . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15
Compatibility  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16
Target audience. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16
Contents of this manual. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16
Terms and abbreviations used in this manual . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17

Purpose of the manual
This manual describes the Drive composer PC tool and instructs how to use it in the 
commissioning and maintenance of ABB drives.

Applicability
This manual applies to the Drive composer PC tool available in two different versions:
• Drive composer entry, DCET-01

• Drive composer pro, DCPT-01 (code: 3AUA0000108087).

You can download Drive composer entry for free by navigating to www.abb.com/drives 
and selecting Drive PC Tools. Drive composer pro includes all features and is available 
through ABB sales channels. Both versions require registration.

Note: In this manual, the features available only with Drive composer pro are indicated as 
“(pro)”.



16   Introduction to the manual
Compatibility
Drive composer is a software tool for all ABB common architecture drives and devices. 
The tool supports following drive families:

• ACS880

• DCS880

• ACS580

• ACH580

• ACQ580

• ACS560

• ACS480.

Target audience
The reader is expected to be an automation engineering professional or an electrician and 
familiar with drive products and the concepts regarding their commissioning and operation, 
including the parameter system of ABB drives. Also a basic knowledge of Microsoft 
Windows operating system is needed.

Contents of this manual
The manual consists of following chapters: 

Drive composer 
version

Compatible features

Drive composer entry • Offers basic features common to all compatible drives.

• Connections to the drive with an Assistant control panel is common for all 
compatible drives and devices.

Drive composer pro • Offers a variety of features and software modules whose availability is 
dependent on the connected drives and option modules. 

• Recognizes the connected drive based on type code and firmware version and 
then adapts the availability of features accordingly. 

• For non-recognized, but compatible drives, the same common basic features 
are available than with Drive composer entry.

• For ACS800 drives: Has limited support (parameter editing and monitoring) and 
requires DriveWindow 2.40 installation on the same PC.

Chapter name What it contains

Introduction to the manual Provides information on the applicability, compatibility, target audience and 
the purpose of the manual

Overview of Drive composer Lists the main features of the Drive composer software and instructs how 
and where it can be run, and how to get help and additional information

Installation and uninstallation 
of Drive composer

Describes how to install and uninstall the Drive composer software

Connections Describes how to make a connection with a drive through USB or Ethernet

Main user interface 
components

Describes the main user interface components of the Drive composer PC 
tool, including the menus

Parameter window Describes how to use the parameter window

Monitor window Describes how to use the monitor window
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Terms and abbreviations used in this manual

Workspace handling Describes the workspace functionality

Event logger Describes how to use the event logger

Diagnostics Describes how to troubleshoot a drive with the Support package button of 
Drive composer and the data logger included in the drive

Control diagrams (pro) Describes how to use the control diagrams

FSO configuration Contains the configuration procedure of the FSO-12 and FSO-21 safety 
functions with Drive composer pro and provides an example of how to con-
figure the optional FSO-12 and FSO-21 safety functions module

Other functions Describes common functions that are not associated with any view or win-
dow. For example, instructions on creating backup of a drive, using the 
Drive parameter conversion tool, using the PSL2 data viewer, and so on

Annexure A: Creating DIB 
service report template

Describes how to create a DIB service report template. Applicable for ABB 
internal users only.

Term or abbreviation Explanation

Alarm limit of monitoring You can set a low or high alarm limit for monitoring. Color(s) of the signal(s) 
change(s) on the monitoring graph area if the limit is reached.

Assistant Provides predefined steps for setting the parameters of the drive. For example, 
the basic start-up assistant.

Assistant control panel Control panel with an USB connector enabling a PC tool connection for 
common architecture drives. Assistant control panel is a generic name for 
ACS-AP-I and ACS-AP-S panels.

Autoscaling Y-axis scaling is set automatically when this button is enabled. User-defined y-
axis limits are then disabled.

Note: Zooming is not possible in the Autoscaling mode.

Backup Backup of the drive. Backup can be created with Drive composer or with 
control panel*. The Drive composer backup file (.dcparamsbak) includes all 
parameters, adaptive program and user sets.

With a backup file from an old drive, you can quickly configure a new drive or 
restore configuration after firmware update.

Note: Backup file does not include firmware, IEC program or license.

* Refer to control panels user’s manual.

Basic control panel Control panel with limited basic functionality used with common architecture 
drives.

Bit mask of monitoring You can filter bits of the Status word and monitor them individually.

BOL Business Online. A common customer interface with electronic integration and 
order entry to all ABB business units.

Common architecture 
drives

For example, ACS880, DCS880, ACS580, ACH580, ACQ580, ACS560 and 
ACS480.

Compare parameters You can compare parameters between drives or between a drive and a file to 
find out differences.

Control diagrams Graphical presentation of the drive reference chain or other function. Shows 
online values of a parameter, switch positions and signals. Parameters can be 
modified online. Functionality is not available for all drives.

Chapter name What it contains
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Copy/Download 
parameters

Visible parameters of a parameter window or custom parameter window are 
copied/downloaded to a drive.

Cursor tool Monitor window has a double cursor tool and the positions of cursors can be 
freely set in the monitor window. y2—y1 and x2—x1 differences are calculated.

Custom parameter 
window

You can create windows and drag drop (copy) parameters to these windows. 
You can also change parameter values in the window and save the changes for 
using in offline mode. The Filename extension for custom parameters is 
*.dccustparams.

Data file viewer In the Demo/Offline mode, the monitor window can be used as a data file 
viewer when saved monitored data (*.dcmon) or data logger data is analyzed.

Data logger Signals are buffered inside a drive with a fast sample interval. Can be triggered 
and uploaded to the monitor window to be analyzed.

Demo/Offline In Demo mode you can only view the default parameter values and settings in 
a pre-configured file. The FSO configuration file can be edited only in demo 
mode (for offline configuration).

In Offline mode you can set/view the saved parameter files offline. 

DIB Drive Installed Base (DIB) is a knowledge base containing information about 
drives. Drive composer is the client application for DIB service which is used to 
register a drive and to create service reports.

DriveAP Adaptive Programming of a drive. Functionality of a drive can be modified by 
adding some IEC 61131 -based blocks. Adaptive Programming can be done 
also with an Assistant control panel.

Note: Adaptive Programming is not available with all drives.

EDS Electronic Data Sheet. EDS files are simple text files used by network 
configuration tools to identify products and describe the properties of these 
products and to commission them on a network.

Event logger Consist of faults, alarms and events. Only faults stop the drive. Latest faults 
and all Electronic Data Sheet arms are also seen in the parameter interface 
group 4, Warnings and Faults.

FENA-11 Ethernet adapter module for ABB drives.

LOC/REM LOC denotes local control of the drive, either with an Assistant control panel or 
with Drive composer PC tool. 

REM denotes that drive is remotely controlled by the fieldbus master PLC or by 
I/O connections.

Lock/Unlock parameter Parameter can be locked by a drive. You can only view the parameter values, 
but cannot modify them. 

Macro script User-written sequence of macro statements for reading and writing 
parameters/signals. Filename extension for macro scripts is *.p.

Monitoring You can set parameters or signals to the monitor window. Values are collected 
with the sampling interval and drawn to a window.

NLS support National Language Support, the user interface (UI) of Drive composer can be 
easily modified by editing language files found in the LANG folder of the Drive 
composer PC tool. 

Online/Offline In Online mode PC tool is connected with the drive. 

In Offline mode PC tool is not connected with the drive. In Offline mode it is 
possible to open parameter files, save monitored data, etc.

Term or abbreviation Explanation
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OPC server OPC DA server interface for Drive composer pro that allows other programs, 
such as Control Builder Pro (Advanced drive programming), to communicate 
with the drive.

Refresh the parameter Parameter values are updated when a group is opened. You can set 
parameters to the Auto-update mode or refresh the value manually. Signals are 
always updated automatically. Signals are bolded in the parameter list.

Report You can use report templates for energy savings, commissioning and 
maintenance. Templates can be modified.

Restore You can restore the drive. You can select the parameters to be restored during 
the restore operation. For example, motor identification run results can be 
restored or deleted during the restore operation. Can be used for cloning 
drives.

Save parameters Visible parameters of a parameter window or custom parameter window are 
saved to a file. Filename extension for saved parameters is *.dcparamsbak.

Note: Some values are not editable in the Offline mode.

Support diagnostics 
package

You can collect all data from a drive for troubleshooting purposes by clicking a 
button in Drive composer or on an Assistant control panel.

Workspace Workspace consists of the user interface status, such as parameters shown in 
the custom parameter window(s) and their status. You can save the current 
workspace status to a file and restore it later. Custom parameter windows with 
their contents and the monitor window contents (signals selected, scalings, 
colors) are saved to a workspace. You can set one default workspace. 
Filename extension for the workspace is *.dcxml.

Term or abbreviation Explanation
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2

Overview of Drive composer

Contents of this chapter
This chapter briefly lists the main features of the Drive composer software and instructs 
how and where it can be run, and how to get help and additional information.

See topics:
Drive composer PC tool overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  21
Supported features  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  22
Drive composer entry Vs pro . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  23
System requirements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  25

Drive composer hardware requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
Computer hardware requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
Software requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

Drive composer PC tool overview
Drive composer is a 32-bit Windows application for commissioning and maintaining ABB 
common architecture drives.

The full version is called Drive composer pro and the limited version is called Drive 
composer entry. Both versions include a demo mode that allows you to test the user 
interface functionality, edit parameter files offline (pro) or open and analyze the saved or 
monitored files without connecting to a physical drive. You can edit the safety configuration 
file (with sanity check) only in demo mode for offline configuration. 
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Supported features
With Drive composer, you can:
• control a drive: start, stop, direction, speed/torque/frequency reference

• monitor the operation and status of a drive

• view and adjust drive parameters

• monitor signals in numerical and graphical (trending) format

• work simultaneously with multiple drives like master and follower drives (pro)

• display control diagrams of a drive for parameter setting and diagnostic purposes (pro)

• create user-specific workspaces by customizing parameter windows

• configure the optional FSO-12, FSO-21 safety functions module (pro)

• handle workspaces

• create and execute macro scripts (pro)

• use Ethernet-based fieldbus adapter modules for PC tool communication (one-wire 
solution, Profinet, Ethernet IP) (pro) or a drive-embedded Ethernet port

• use the USB port of an Assistant control panel for an USB connection

• use an OPC-based commissioning and maintenance tool (pro)

• connect to Drive Installed Base service portal and do following tasks: register a drive, 
search drive information, create service reports
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Drive composer entry Vs pro
The table lists the features supported in the two versions of Drive composer.

Feature Drive composer

 entry pro

Parameters can be modified Yes Yes

Parameters can be searched Yes Yes

Parameters changed by the user (or automatically updated) have an orange 
background

Yes Yes

Parameters can be saved to a file Yes Yes

Parameters can be copied/downloaded to a drive Yes Yes

Parameter windows can be customized Yes Yes

Parameters can be printed Yes Yes

Parameters can be edited offline No Yes

Parameters can be compared between parameter lists or drives No Yes

Data for the support service can be collected by clicking the Support package icon Yes Yes

As a simple monitoring method for basic purposes, up to 8 signals can be monitored Yes Yes

Monitored data can be saved to a hard drive of a PC Yes Yes

Monitored data can be exported to a PC by using the tab separated file Yes Yes

For a professional analysis of a single drive or multidrive, maximum 26 signals can be 
monitored

No Yes

Contents of an event logger (faults, warnings) can be viewed Partly Yes

Contents of the System info (drive serial number, modules, versions, SW etc.) can be 
viewed

Yes Yes

Backup/Restore can be used for restoring or cloning a drive Yes Yes

Advanced restore can be used for restoring a set of components/parameter settings No Yes

Network Backup can be used for taking a backup of an entire multidrive with single 
click.

No Yes

PC can be used to analyze the data logged in a drive by a data logger No Yes

Macro scripts can be created and executed No Yes

Safety settings can be configured to a safety functions module (FSO) No Yes

Point-to-point USB can be connected through a panel port Yes Yes

Network drives can be connected via Ethernet or with a panel bus No Yes

Control diagrams of a drive can be used for parameter setting and diagnostic purposes No Yes

User interface is available in different languages Yes Yes
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Create and edit Adaptive Programs No Yes

Support of Virtual drive smart components No Yes

Connect to Drive Installed Base service portal to: register a drive, search for drive 
information, create service report

Yes Yes

Feature Drive composer

 entry pro
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System requirements

 Drive composer hardware requirements

 Computer hardware requirements  

 Software requirements

Cable type For...

USB type A (PC) type mini B (panel) cable

Note: ABB recommends to use ferrite core 
cables.

connecting Drive composer entry/pro through the USB port of 
the control panel to a drive (maximum 3 meters)

Ethernet cable RJ45 connecting through FENA-11 or embedded Ethernet

Hardware Specification

Computer IBM compatible PC

Processor  Intel i3 or equivalent AMD processor

Memory 1GB RAM

Display 1024 x 600 display resolution with 256 colors

Hard disk At least 150 MB free hard disk space

Storage CD drive

Communication port One free USB port or Ethernet port

Software Specification

Operating system Windows 7, Windows 8.1 or Windows 10 (32- or 64-bit)

Framework .Net framework 4.6.2 or higher 
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3

Installation and uninstallation of 
Drive composer

Contents of this chapter
This chapter describes how to install and uninstall the Drive composer software. 

See topics:
Determining the current Drive composer version  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  28
Installing Drive composer with the installer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  29
Uninstalling Drive composer with the installer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  32
Registering Drive composer pro  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  33

Registering Drive composer pro (Online) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Registering Drive composer pro (Offline) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
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Determining the current Drive composer version

To know the version of the Drive composer PC tool, go to Help → About the product. 
The About the product dialog box displays the Drive composer version.

Figure 1. About the product dialog box
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Installing Drive composer with the installer
Note: 
• ABB recommends to uninstall all previous versions of Drive composer before you 

install a new version. See section Uninstalling Drive composer with the installer. 

• Close all applications before starting the installation.

1. Run the setup.exe file from the folder where you unzipped the Drive composer files.

2. With Windows 7, right-click on the setup.exe file and select Run as administrator.

Figure 2. Installing Drive composer: Run as administrator

3. In the Drive composer pro - InstallShield Wizard, click Next >.

Figure 3. Installing Drive composer: Setup wizard window
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4. Choose a destination folder and click Next >.

Figure 4. Installing Drive composer: Destination folder window

5. Click Install to start the installation.

Figure 5. Installing Drive composer: Install window
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If Drive composer installation is complete, click Finish. Now Drive composer is ready for 
use.

Figure 6.  Installing Drive composer: Installation completed window
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Uninstalling Drive composer with the installer
1. Go to Control panel → Programs → Program and features window and select the 

installed Drive composer pro program. Click Uninstall.

Figure 7. Uninstalling Drive composer

2. Click Yes to uninstall Drive composer pro application.

Figure 8. Uninstalling Drive composer: Confirm removal of Drive composer
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Registering Drive composer pro 
Drive composer pro includes a license and requires registration. During the first launch of 
the software, preferably you can register online. You can also make offline registration if 
Internet connection is not available on the PC where Drive composer is installed.

You can also run Drive composer pro for 30 days in fully functional evaluation mode.

 Registering Drive composer pro (Online)

During the first launch, Drive composer pro prompts to enter the registration code or the 
license key.

Figure 9. Online registration: Product activation

Fill in the registration code and click Activate. You are forwarded to the registration form. 
Fill all details accurately and proceed with registration.

 Registering Drive composer pro (Offline)

Note: Offline registration is possible only during the 30 days evaluation period.

To make offline registration, 

1. Contact your local ABB representative and provide the following details:
• Name of the registrar

• E-mail address

• Company name

• Field of industry (optional)

In this manual registration process, ABB support personnel will provide you a license file 
that you can use for offline registration. 

2. In Drive composer pro, go to Help → Enter licence code.

Figure 10. Offline registration: Enter licence code
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3. In the Product activation window, type the license key or the registration code.

Figure 11. Offline registration: Enter registration code

4. Click Activate.

If the code is activated, use the license file provided.
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Connections

Contents of this chapter
This chapter describes how to make a USB connection or an Ethernet connection to an 
ABB drive with Drive composer.

See topics:
Using Assistant control panel drivers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35
Connecting to a drive with an Assistant control panel for the first time . . . . . . . . . . . . . . . . .  36

Cable type  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
Connecting to drive with Assistant control panel  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

Changing the language settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  38
Connecting to a drive through an Ethernet network  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  40

Ethernet network connection  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
Creating an Ethernet network connection with Drive composer (pro)  . . . . . . . . . . . . . . . . 40

Connecting network drives (pro) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  49
Panel bus network connection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
Creating a panel bus with Drive composer (pro)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
Connecting to the panel bus with Drive composer (pro). . . . . . . . . . . . . . . . . . . . . . . . . . . 50

Sharing connection (pro) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  51

Using Assistant control panel drivers
You can connect an ABB drive to an Assistant control panel (ACS-AP-x) through USB by 
installing the required USB device drivers. Drive composer installer installs the required 
drivers automatically, so no user actions are needed.

If the installer failed to install the drivers automatically, you can manually install the USB 
drivers by downloading the tool from software tools website: 

http://new.abb.com/drives/software-tools/drive-composer

Follow the instructions provided with the drive package.

http://new.abb.com/drives/software-tools/drive-composer
http://new.abb.com/drives/software-tools/drive-composer
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Connecting to a drive with an Assistant control panel for 
the first time

 Cable type

To establish a connection between Drive composer and drive, 
• connect a USB type A (PC) type mini B (panel) cable to the USB port of the computer 

and the USB port of the Assistant control panel (ACS-AP-x panel). 

• use a USB cable of maximum length three meters.

• use separate USB/485 adapter if the drive is used without an Assistant control panel 
or with a Basic control panel.

 Connecting to drive with Assistant control panel

1. Connect your PC to the Assistant control panel with a USB cable.

Figure 12. USB connection between Assistant control panel and PC

The following text appears on the Assistant control panel screen: “USB connected”.

Note: The Assistant control panel cannot be used when it is connected to a PC.

2. Launch Drive composer by double-clicking Drive composer entry/pro.exe.

3. Click Connect if you want to connect to the drive or click Demo if you want to choose 
the Offline mode. 

Figure 13. Connecting to a drive: Connect/Demo button

ABB drive
Assistant
control
panel

PC with 
Drive 

composer

USB cable
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You can also select the dedicated connections to the drive:

Note: 
• The status LED starts flickering in the Assistant control panel indicates data 

transfer between drive and PC. The LED keeps blinking as long as there is a PC 
tool connected to the drive. The welcome dialog box is shown on the screen 
indicating that the application is being initialized.

• First time connection, parameter texts are loaded from the drive and this might 
take a few minutes depending on the drive type.

Drive composer loads the drive parameters and the following window displays.

Figure 14. Connecting to a drive: Parameters loaded

Drive composer is now connected online with the drive. If you have a single drive and 
a point-to-point connection, refer to chapter Parameter window.

4. If Drive composer failed to connect online with the drive, go to View → Settings to 
check your COM settings and click View → Refresh (Ctrl + R) to reconnect Drive 
composer to the drive.

Connections Description

DDCS enabled (ACS800 only) Connects to the drive through DDCS (fiber optic) communication. This 
option is applicable to ACS800 drive type only.

USB/COM enabled Connects to the drive through USB connection. Use this option only when 
you want to connect to the drive through serial connection, example, USB 
cable to ACS-AP-x panel.

Ethernet enabled Connects to the drive through Ethernet network.

Virtual drive enabled Connects to the Virtual drive smart component. This option is applicable 
only when you have Automation Builder installed in the PC.

Comm settings Opens another dialog where you can configure the connections in more 
detail other than the above three
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Changing the language settings
To change the language settings of the Drive composer UI, 

1. Go to View → Settings. 

Figure 15. Changing language settings: View → Settings

2. In the Settings window, choose the required language for the Drive composer UI.

Figure 16. Language settings
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• Drive composer default language–selects the default language of the menu or 
button text in Drive composer.

• Drive default language–selects the default language for parameters.

By changing language settings you can always use the same language when you connect 
Drive composer to the drive. 

3. After changing the language settings, click View → Refresh (Ctrl + R) or restart the 
Drive composer application.

Note: Some elements might require application restart to update the selected language.
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Connecting to a drive through an Ethernet network

 Ethernet network connection

Some ABB drives have control boards with an embedded Ethernet port and some drives in 
which the Ethernet connection is made with the FENA-11 Ethernet adapter module. For 
the installation of the adapter module, see FENA-01/-11 Ethernet adapter module user’s 
manual (3AUA0000093568 [English]).

Note: Configure the PC/Ethernet Switch firewall to allow a connection for Drive composer 
pro (port http 80 and UDP), otherwise disable firewall. 

 Creating an Ethernet network connection with Drive composer (pro)

1. Connect the FENA module to a drive.

2. Create a point-to-point connection from Assistant control panel or Drive composer to 
each drive.

3. If you will use only one adapter module with the drive, enable the FENA-11 by setting 
parameter 50.01 FBA A enable to Enable and parameter 50.21 FBA A Timelevel sel to 
Fast (or Monitoring for Tool network only).

4. If you will use two fieldbus adapters with the drive and the FENA-11 has been installed 
as FBA B, enable the FENA-11 by setting parameters 50.31 FBA B enable to Enable 
and 50.51 FBA B Timelevel sel to Fast (or Monitoring for Tool network only).

5. Set a static IP address for each drive. See FENA-01/-11 Ethernet adapter module 
user’s manual (3AUA0000093568 [English]).

Figure 17. Ethernet connection: IP settings of the drive with Drive composer

6. Refresh the settings with parameter 51.27 FBA par refresh.

Note: Refreshing the Node setting will lose the communication to the drive. To re-establish 
the connection with the drive, select View → Refresh.

7. Name each drive to facilitate the recognition of drives when creating an Ethernet 
network connection.

In the System info tab, type the Drive name and click Set.

Figure 18. Ethernet connection: Naming a drive with Drive composer
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Note: The drive name changes only after you refreshed the view. The previous names 
in other existing workspaces are not affected.

If you use Assistant control panel, name the drive from the Setting menu of the panel.

8. Configure the TCP/IP address of your PC. In this example the TCP/IP address is 
192.168.0.1. For more information on configuring the TCP/IP address, see
• Configuring the TCP/IP address with Windows XP or

• Configuring the TCP/IP address with Windows 7.

Configuring the TCP/IP address with Windows XP

1. Go to Control panel → Network and Internet Connections → Network 
Connections.

2. In the Network Connections window, double-click the required connection.

Figure 19. Configuring TCP/IP address: Network Connections window
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3. Click the Properties button. The Local Area Connection Status dialog box appears.

Figure 20. Configuring TCP/IP address: Local Area Connection Status

4. Select Internet Protocol (TCP/IP) and click Properties.

Figure 21. Configuring TCP/IP address: Local Area Connection Properties
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5. Select Use the following IP address and type the IP address and the subnet mask.

Click OK.

Figure 22. Configuring TCP/IP address: Use IP address

TCP/IP address configuration is completed.
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Configuring the TCP/IP address with Windows 7

1. Go to Control Panel and click View network status and tasks.

Figure 23. Configuring TCP/IP address: Win 7 Control Panel

2. Click Change adapter settings on the left pane. A Network connections window 
displays.

Figure 24. Configuring TCP/IP address (Win 7): Adapter settings

3. Double-click Local Area Connection.

Figure 25. Configuring TCP/IP address (Win 7): Local Area Connection
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4. Click Properties.

Figure 26. Configuring TCP/IP address (Wind 7): Local Area Connection Status

5. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.

Figure 27. Configuring TCP/IP address (Win 7): Local Area Connection Properties
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6. Select Use the following IP address, type the IP address and subnet mask and click 
OK.

Figure 28. Configuring TCP/IP address (Win 7): Use IP address

7. Connect the RJ45 cable between the FENA module and PC. Alternatively, connect all 
drives and PC to the same Ethernet switch.
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8. Open command prompt (cmd.exe) and ping all the drives that you have configured.

Figure 29. Configuring TCP/IP address (Win 7): Ping drives

Note: Open http port 80 of the firewall in your computer to enable Drive composer pro to 
communicate with drives.

9. Open Drive composer pro. In the Welcome window, make sure Ethernet enabled is 
checked and click on Comm settings button.

Figure 30. Configuring TCP/IP address (Win 7): Ethernet enabled
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10. In the Drive Ethernet Configuration Tool window, click Scan → Scan Network. Make 
sure Auto configuration mode is checked. 

Figure 31. Configuring TCP/IP address (Win 7): Communication settings

Drive composer scans all the COM ports and Ethernet ports to find drives. 
If problems arise, see Ethernet tool network for ACS880 drives application guide 
(3AUA0000125635 [English]).
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Connecting network drives (pro)

 Panel bus network connection

You can connect all ABB drives with an ACS-AP-x panel using a daisy-chain connection 
through the control panel ports as a network either for a PC tool or a panel bus connection.

Note: Some ABB drives control boards (for example, ZCU-13) do not have any daisy-
chain connectors. For those drives, a panel bus connection can be created with FDPI-02 
option modules. See FDPI-02 diagnostics and panel interface user’s manual 
(3AUA0000113618 [English]) for more information.

Figure 32. Connecting network drives: Creating a panel bus

 Creating a panel bus with Drive composer (pro)

1. Create a point-to-point connection from the Assistant control panel or Drive composer 
to each drive.

2. Set an independent node ID for each drive (with parameter 49.01 Node ID number).

The node ID must be between 1…32.

3. Refresh the settings (with parameter 49.06 Refresh settings).

Note: Refreshing the Node setting will lose the communication to the drive. To re-establish
the connection with the drive, select View → Refresh.

4. With parameter 49.05 Communication loss action, define how the drive reacts to a 
control panel (or PC tool) communication break by selecting No action.

Figure 33. Creating a panel bus: Panel port settings

5. Give a name for each drive to facilitate the recognition of drives when creating a panel 
bus connection.
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In the System info tab, type the Drive name and click Set.

Figure 34. Creating a panel bus: Naming a drive

Note: The drive name changes only after you refreshed the view. The previous names 
in other existing workspaces are not affected.

If you used Assistant control panel, name the drives through the Setting menu of the 
panel.

6. Remove all panels connected to drives.

7. For connecting the drives in a daisy-chain, connect a standard RJ45 (straight CAT5) 
cable on the left-hand side connector of the Assistant control panel in the first drive 
(the left-hand side drive in figure Connecting network drives: Creating a panel bus on 
page 49).

Note: Heavy-industry type RJ45 male connectors do not fit into the drive side female 
RJ45 slot

8. Connect a standard RJ45 (straight CAT5) cable from the right-hand side connector of 
the Assistant control panel in the first drive to the left-hand side connector of the 
Assistant control panel in the second drive.

9. Continue chaining the rest of the drives as described above.

10. If there is a long distance between the first and last drive in a panel bus, set the 
resistor to the ON position in the last node.

 Connecting to the panel bus with Drive composer (pro)

1. Connect a USB cable between the Assistant control panel and your PC.

2. Double-click Drive composer pro.exe to launch Drive composer.

The status LED starts flickering on the Assistant control panel.

3. Drive composer starts scanning all selected networks and loads the connected drives.

4. Make sure you see all drives in the Drives list.

Notes: 
• If you see a missing drive, close the PC tool and try again. If you still do not see all 

drives, check Group 49 Panel port communication for the settings of the missing 
drives.

• Drive composer does not automatically open any parameter window or other 
object.

5. Select and click a drive from the Drive list.
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Sharing connection (pro)

1. Go to View → Settings. 

2. In the Settings screen, select the option Share connection with Automation 
Builder to enable simultaneous connection to the same drive from both applications.

Figure 35. Connection sharing: Settings

3. Click Save to save the new settings.

4. You may be prompted to restart Drive composer. Click OK, to restart.
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Main user interface components

Contents of this chapter
This chapter describes the user interface (UI) components and how to use them.
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Drive composer UI overview
The Drive composer user interface consists of the following parts. 

Figure 36. Overview of the user interface

1 Title bar

2 Menu bar

3 Drive control panel

4 Drives list panel (see also Drives list panel: status indication)

5 Status panel (including the output view of the selected drive).

6 Working area for parameter windows, event logger, control diagrams, assistants etc. 

2 3
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Title bar
The title bar is located at the top of the main window. It consists of the following parts:

 Closing the application

When you close the application, system prompts to confirm. Click Ok to close the 
application. Before closing, Drive composer may:
• warn you about releasing control of the drive if the drive is controlled locally by Drive 

composer

• prompt you to save the workspace with unsaved changes. See Saving the workspace 
with unsaved changes.

• remind you to save your monitor data

• remind you of unfinished printing.

Note: If you disconnect the cable from the drive before closing Drive composer there might 
be a long delay in operation.

 Alternate methods to close the application

You can also close Drive composer by
• double-clicking the System menu icon

• selecting Close in the System menu

• selecting Exit in the File menu

• pressing the shortcut key Alt+F4.

1 System menu icon. See description in System menu.

2 Application name and version number (Drive composer entry/pro)

3 Name of the workspace (if there is an active workspace)

4 Minimize button–has the same function as Minimize in the System menu. With this button, you can 
reduce the main window to the task bar or a sub-window to the bottom of the window area.

5 Maximize/Restore Down button (the name depends on the status of the maximized window)–has the 
same function as Maximize or Restore in the System menu.

• With the Maximize button, you can enlarge the window to fill the available space.

• With the Restore Down button or the Restore (from system menu), you can restore the window to 
the size and position it had before it was maximized.

Note: 

• You can also maximize or restore the window by double-clicking the title bar.

• You can move a window by dragging the title bar or you can move a dialog box by dragging its title 
bar. But you cannot move a window by dragging the title bar if you have maximized or minimized a 
window.

6 Close button–has the same function as Close in the System menu. With this button, you can end the 
Drive composer session. See also description of Closing the application.

1
2 4

5
6
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 Saving the workspace with unsaved changes

You can close Drive composer without saving the changes to workspace. 

1. Go to View → Settings.

2. In the Settings window, check the option Save workspace on exit.

Figure 37. Save workspace on exit function

The function prompting you to save the workspace with unsaved changes is disabled.
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 System menu

You can open the System menu by

• left- or right-clicking the System menu icon 

• pressing the shortcut key Alt+space bar

• right-clicking within the non-button area of the title bar.

The System menu contains the following commands:

Figure 38. System menu

System menu commands description 

Command Description

Restore Restores the window to its size and position which it had before it was maximized.

This command is the same function as Maximize/Restore Down button in the title bar when 
the window is maximized. 

Move Allows moving the window with arrow keys. To stop moving the window, press ENTER. To 
cancel the move, press ESC.

This function can also be performed by dragging the title bar. 

Size Allows resizing the window with arrow keys. To stop resizing the window, press ENTER. To 
cancel resizing, press ESC.

This function can also be performed by dragging any of the sides or corners of the window.

Minimize Reduces the window to the task bar or to the bottom of the window area.

This command is the same function as the Minimize button in the title bar.

Maximize Enlarges the window to fill the available space.

This command is the same function as the Maximize button in the title bar when the window 
has not been maximized.

Close Ends the Drive composer session.

This command is the same function as the Close button in the title bar. 
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Menu bar
The menu bar is located below the title bar. It contains the following drop-down main 
menus:
• File

• Edit

• View

• Tools (pro)

• Help.

 Using the menu bar

• Click on a menu name to execute a command

• Use arrow keys to navigate between the menus

• Press ENTER to execute a highlighted command

• Press ESC, to close a menu

• Use also shortcut keys to execute the commands.

 File menu

The File menu is always located in the menu bar. See description in File menu commands 

description.

Figure 39. File menu → New

Figure 40. File menu → Open
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File menu commands description

Command Sub-command Description Keyboard 
shortcut

New.. Custom 
parameter set

Creates a new parameter set window. You can also set 
this window as the default.

Ctrl+N

Open.. Open the latest 
saved workspace

Opens the latest saved workspace. Ctrl+L

Open Workspace Opens a new window where you can select the saved 
workspace to be opened. 

Ctrl+O

Custom 
parameter file

Opens a new window where you can open the saved 
custom parameter file.

Alt+W

Monitor file Opens a window to open the parameter file for 
monitoring.

Ctrl+M

Parameter file Opens a new window where you can select the saved 
parameter file to be opened. 

Alt+P

Open support 
package

Opens a new window where you can select the saved 
support package file to be opened.

-

Save 
workspace

- Saves the active workspace of a file. Ctrl+S

Save 
workspace as 
default

- Saves the active workspace to default workspace. The 
default workspace opens automatically when Drive 
composer is opened.

Ctrl+D

Exit - Ends the Drive composer session. Alt+F4

Print - Prints the parameter screen. Ctrl+P

Print real-time 
monitor view 
(pro)

- Prints the monitor screen. -
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 Edit menu

The Edit menu is always located in the menu bar.

Figure 41. Edit menu

The menu contains the language commands with which you can select the language for 
the Drive composer user interface.

Note: Restart the Drive composer to see the language changes.

 View menu

The View menu is always located in the menu bar.

Figure 42. View menu
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View menu commands description

Command Description Keyboard 
shortcut

Normal text font size Selects normal font size.

Note: The change in the font size does not affect the size of the 
monitor window font.

Ctrl+F7

Large text font size Selects larger font size. Ctrl+F8

The largest text font 
size

Selects the largest font size.

You can also change the font sizes using the following A-letter icons. 

Ctrl+F9

Tabs Changes working area to be viewed as tabs. 

Note: The monitor window cannot be tabbed.

Alt+T

Floating windows Changes working area to a separate window.

Note: The monitor window cannot be a floating window.

Alt+F

Tile horizontally Changes floating windows to be tiled horizontally. Alt+H

Tile vertically Changes floating windows to be tiled vertically. Alt+V

Cascade Changes floating windows to cascade. You can resize and freely 
locate the cascaded windows in the working area.

Alt+C

Settings Defines language and connection configuration. 

Enables to

• save workspace settings

• disable local control

• share connection to the same drive

Allows to 

• select temporary file location

• set the appropriate DIB server location.

-

Disconnect Disconnects Drive composer from the drive. Ctrl+Q

Refresh Creates a new connection between Drive composer and the drive, 
which means, uploading parameter information from a single drive 
and creating a new connection with multidrives.

Ctrl+R
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 Tools menu (pro)

The Tools menu is located in the menu bar. The commands of the Tools menu may vary 
between different software versions and drives.

Figure 43. Tools menu

Tools menu commands description

Command Description Keyboard 
shortcut

Safety Configuration Report Prints safety functions configuration report if FSO module is 
installed.

-

Backup network Creates backup of all connected drives in a PC tool network. 
See Creating a backup of a drive (page 162).

-

Compare drive data Compares parameters of two drives or a parameter file and a 
drive or two parameter files.

-

PSL2 data logger Uploads PSL2 data logger files from the drive flash memory to 
PC local hard drive. This option is applicable only in BCU-x2 
control unit. See Using the PSL2 data logger (pro) on 
page 171.

-

PSL2 Data Viewer Opens and views contents of the uploaded PSL2 data logger 
files in the PC local hard drive. See Using the PSL2 data 
viewer (pro) on page 173.

-

Localization Editor Allows reading texts from the drive to make changes and to 
update texts to the drive. See Using the Localization editor on 
page 166.

-

Drive Parameter 
Conversion Tool

Converts parameters. See Using the Drive parameter 
conversion tool (pro) on page 168. 

Ctrl+Alt+P
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EDS Export Creates EDS files of a connected drive. Ctrl+I

Application symbols Shows symbols exported from Control Builder Plus application 
to the drive. The application list will remain empty if drive does 
not have Control Builder Plus.

Alt+A

Macro Sets parameter values to multiple networked drives when 
custom window functionality is not sufficient. See Macro (pro) 
(page 137) and Macro commands (page 138).

Alt+M

Register drive Registers an ABB drive in the Drive Installed Base service 
(DIB) portal. See Registering an ABB drive to DIB service 
(page 122).

-

Search drive from DIB Retrieves information of a registered ABB drive in DIB. You 
will need access permissions to DIB portal. See Searching a 
registered ABB drive in DIB (page 127).

-

Create service report Creates service report of a registered ABB drive in DIB. You 
will need access permissions to DIB portal. See Creating a 
service report from DIB (page 130).

-

Command Description Keyboard 
shortcut
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 Help menu

The Help menu is always located in the menu bar.

Figure 44. Help menu

Help menu commands

Command Description Keyboard 
shortcut

Content Opens Drive composer user manual as a PDF file. F1

Firmware manual Opens firmware manual of the connected drive type in a 
separate window as a PDF file. If you selected a parameter or 
some other significant item when you clicked this command or 
pressed F3 key, the appropriate chapter in the firmware 
manual is displayed.

F3

Make support package Creates a single file that can be sent to the local ABB support 
contact if you need any support..

-

Enter licence code (pro) Registers the Drive composer license code, during the first-
time launch of the software. See steps for Registering Drive 
composer pro on page 33.

-

About the product Displays Drive composer software version and copyright text. -
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Drive control panel
The drive control panel is located below the menu bar. It has buttons for controlling a 
connected drive. It also shows the status of the drive.

Figure 45. Drive control panel buttons/items

 Drive control panel buttons/items description

Item 
no.

Button 
name

Description

1 - Name and node number of the currently controlled drive.

2 - Motor icon (clockwise open circle arrow) for drive status indication. For 
description, see Drives list panel: status indication (page 68)

3 Control Allows controlling the selected drive through Drive composer or allows releasing 
control of the drive.

4 Reset fault Sends a reset command to the drive. If the fault is not active, the drive clears it.

5 Start Starts the currently controlled drive. A motor connected to the drive starts rotating 
according to the set reference value.

6 Stop Stops rotation of the motor connected to the currently controlled drive. 

7 Coast stop Coasts the currently controlled drive to stop.

8 Reference Allows entering a new reference value. The Reference field will show the current 
reference value used in the drive. 

When you click the Reference field, a tooltip shows the minimum and maximum 
limits for the reference and current/actual reference value. 

For reverse direction, set the value manually with negative (-) sign.

9 Set Enforces the value in the reference value field to the currently controlled drive. You 
can also perform the same command by pressing ENTER.

10 Active 
reference

Displays the active reference value.

11 Step Activates step cycle with the reference value.

Allows modifying Step type, Step value and Step duration with reference 
value. The available configuration is dependent on the connected drive.

2 1 3 4 5 6 7 8 910 11
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 Using the drive control panel to start the drive

1. Set the drive parameter values necessary to start the drive. See firmware manual of 
the drive.

2. Click Control button.

The control box indicator changes to LOC.

3. Enter a reference value and press ENTER or click the Set button.

4. Click Start.

The drive starts. The indicator box arrow changes to green.

Note: Limit settings in parameter group 30 affect the reference limits.
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Drives list panel
The drive list panel shows all connected drives and open files. The drives status is 
indicated with a motor icon (clockwise open circle arrow). For description of status, see 
Drives list panel: status indication.

Figure 46. Drive list panel: Connected drives and context menu items

When you click on a connected drive type, a pop-up window/context menu appears with 
different drive view types.  

You can open those views either as new tabs or floating windows. If an active window is 
associated with a drive or a file, the corresponding tree item is highlighted in the drive list.

Drive view Description

Parameters See Parameter window.

Amplitude logger See Amplitude logger (pro).

Datalogger See Datalogger (pro).

Adaptive Programming See Adaptive programming.

Diagrams See Control diagrams (pro).

System info See System info.

Event logger See Event logger.

Backup/restore See Creating a backup of a drive and Restoring a drive.

Register drive See Registering an ABB drive to DIB service.

Search drive from DIB See Searching a registered ABB drive in DIB.

Create service report See Creating a service report from DIB.
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 Drives list panel: status indication

Status Description

Stopped drive A grey circle arrow indicates a stopped drive.

Running drive A green circle arrow indicates a running drive.

Faulty drive A red circle with a white cross (x) indicates a faulty drive.

Alarm An orange background means that a drive has an alarm.

Broken connection A red broken line (—/ /—) means that the connection to a drive 
has broken.
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Working area
The working area shows the following views:
• Parameter windows

• Custom parameter windows

• Event logger

• System info

• Control diagrams

• Assistants, and so on.

 Using the working area

In the working area, you can 
• use either tabs or floating windows

• adjust the size of the working area by dragging the white separating line up/down

• adjust the size of the drive list to the left/right

• resize the windows that are not maximized by dragging any corner

• scroll the content using scroll bars on the side or bottom of a window.

 The user interface is tabbed by default. You can change the order of tabs by dragging 
them. You can open tabs for a single drive or for multiple drives.

Figure 47. Working area: Tabbed user interface

You can set the working area to a floating window. For example, parameter window, event 
logger, system info, etc. can be shown as floating windows. You can also tile the floating 
windows vertically or horizontally, or cascade using the View menu commands.
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Figure 48. Working area: Floating windows
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6

Parameter window

Contents of this chapter
This chapter describes the parameter and custom parameter windows.

See topics:
Parameter window overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  72
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Parameter window overview
The parameter window view displays parameter groups, parameters and their values for 
the associated drive or a file. The working area can show several parameter windows. The 
headline of each parameter window shows which drive it belongs to. 
• With Drive composer entry, the parameter window opens only when the drive is 

connected. 

• With Drive composer pro, the parameter window opens by clicking on the selected 
drive in the drive list panel and selecting Parameters.

Figure 49. Parameter window: Open drive parameters
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 Parameter window command icons

Icon Description

Expands/collapses parameter groups. When parameter groups are 
expanded, all parameter values are read once from the drive.

Saves parameters to a file. Saves visible parameters to a file. File 
extension is dcparams(bak).

Enables you to search parameter lists with a keyword. Search is 
activated/deactivated by clicking the Filter check box. When the Filter 
check box is unchecked all parameters are seen.

Note: If parameter groups have not been expanded, the first search takes 
about 30…60 seconds.

Allows you to select/deselect columns to be seen in a parameter window.

Parameters are updated only when a group is opened. With the Enable 
updating function it is possible to set all open and visible groups to be 
updated automatically. Parameters that have been set to be updated 
automatically have a yellow background.

Allows you to download parameters from a file to a drive. With a custom 
parameter window allows downloading offline values to a drive.

Enables you to change the window target, which is useful if you have 
Drive composer pro and you have to check certain parameters of another 
drive. Included only in custom parameter windows.

Provides you with a list of all user-changed parameters if you click the 
check box. These parameters have an orange background.

Allows you to add or remove one parameter or signal or several 
parameters or signals to/from a custom parameter window.
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 Parameter window: view parameters

Figure 50. Parameter window: Selected drive parameters

 Parameters list representation

The parameter window contains different types of parameters. Some of these types are 
identified by colors or bold fonts as shown in the table below:

Illustration Explanation

20.3      Ext1 In1 source                     D1 Normal parameters

1.1        Motor speed used               0.00 rpm Signals (bold)

10.21    RO status                             
Bit names of a parameter can be seen by double-
clicking on the parameter. New window opens.

11.6      DIO1 output source               P.10.1.1 Parameter value is set from another parameter, for 
example, parameter group 10, index 1, bit 1.

11.6      DIO1 output source               P.10.1.1 - Parameter value is an inverted bit of another 
parameter, group 10, index 1, bit 1.

20.1      Ext1 commands                    User has changed the value of a parameter (shown 
with an orange background).
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Note:
• The most common type is the regular parameter. 

• Parameters are normally readable and writable. However, when the drive is running, 
some parameters may be write-protected.

• The parameter view shows: Parameter names, values, units, default values and 
different user sets. The number of user sets depends on the drive type.

• The value of a parameter is read only once. If is necessary to update this value, right-
click and select Refresh the parameter. 

• You can set all visible parameters to update automatically by clicking the Enable 
updating button.

• You cannot modify values of signals. If you attempt to modify a signal, an error is 
indicated. Signals are updated cyclically in the parameter window. 

• Parameter signals are also updated frequently, but you can modify these values.

Navigating parameters and groups

 Updating parameter values

Parameter values are updated if they are modified. 
• To modify a parameter value, double-click the parameter or press ENTER on the 

highlighted parameter. 

• To update a parameter group value, right-click the group name and select Refresh 
group parameters.

 Hidden parameters

In special cases, hidden parameters and groups become available by modifying some 
parameter values. The View → Refresh command updates the whole parameter table. 
For example, group 51 FBA A Settings: When the adapter module is enabled in group 50, 
you can see parameter names by selecting View → Refresh.

Note: Close the parameter window before refreshing and open again after refreshing.

 Alternate formats to view parameters

There are five alternative formats in which parameters are shown: default, binary, 
hexadecimal, integer and float format. 

To change the format of a parameter, right-click and select either Use default format, 
Use binary format, Use hexadecimal format, Use integer format or Use float format.

You can change the widths of the columns by dragging the vertical lines between the 
column headers.
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 Viewing bit names

To see the bit names of certain binary parameters, double-click the value field box. For 
example, see the below parameter 10.1 DI status.

Figure 51. Navigating parameters and groups: Parametet bit names 

To reset a parameter, right-click and select Reset to default.

Parameter values are read once when a group is opened. You can set independent 
parameters from different groups to the Auto-update mode by right-clicking and selecting 
Add to auto-update. The parameters that are updated automatically are seen with a 
yellow background as shown in the following figure.

Note: Signals are automatically updated cyclically
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Figure 52. Navigating parameters and groups: Parameters with yellow background

Parameters or signals can be sent to the monitor window by right-clicking them and 
selecting Send to monitor. Parameters can be copied to a custom parameter window by 
right-clicking them and selecting Copy. In addition, you can drag and drop parameters to a 
custom parameter window.
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Pointer parameters overview
Pointer parameter is a special type of parameter that reads value from the parameter it 
points to. Depending on the pointer parameter, value or bit pointer, its target can be 
another parameter or one of its bits. You can assign Active (false) or Inactive (true) status 
to some pointer parameters.

Figure 53. Pointer parameters: Constant value

Typically, common settings are offered as a selection list. If the selection list does not offer 
the correct pointer, you can set the pointer by selecting Other… from a selection list. 
Select a parameter from the list for a value pointer and then its bit from 0 to 31 for a bit 
pointer.

You can also enter a value manually by selecting the Edit manually check box. Use the 
value form P.#.#.#, where the first # is the parameter group number, the second # is the 
parameter number and the third # is the bit number without leading zeros (for example 
P.2.1.2). The constant values are Active (false) or Inactive (true).
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 Inverting a bit pointer

In the Set pointer parameter window, select Invert value check box.

Figure 54. Pointer parameters: Inverting a bit pointer value

The inverted bit pointer value is shown with the minus sign at the end of the parameter.

Figure 55. Pointer parameters: Inverted bit pointer value with minus sign
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 Setting fieldbus data in/out parameters

Process data transferred to and from the drive/PLC is set with parameter groups 52 and 
53. With an ACS880 drive it is possible to select the data type for each selected 
parameter/signal in these groups.

1. Double-click FBA data in/out parameter and select Other.

Figure 56. Setting fieldbus data in/out parameters: Select data type
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2. Select the format in which the value is handled:16-bit, 32-bit or floating point format.

Figure 57. Setting fieldbus data in/out parameters: Select format

In the parameter window the selections are shown inside brackets: [16], [32] or [F].

Figure 58. Setting fieldbus data in/out parameters: Formats shown inside brackets

Note: 
• The floating point or 32-bit value reserves two slots in the configuration. Consequently, 

if you try to select a value for parameter 52.04 as in the figure above, a Parwrite failed 
error message appears. See the scalings of parameters/signals in ACS880 primary 
control program firmware manual (AUA0000085967 [English]).

• Always check the parameter mapping from the manual of the used fieldbus protocol. 
Example, FENA-01/-11/-21 Ethernet adapter module user's manual 
(3AUA0000093568 [English]) or FPBA-01 PROFIBUS DP adapter module user's 
manual (3AFE68573271 [English]).
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Binary parameters
Binary parameters have a special meaning for each of their bits. These parameters are 
modified in a special Set binary parameter dialog. You can modify the value numerically in 
binary, hexadecimal or decimal format. 
• One way to modify the value in the field is, double-click the value field for each bit. 

Some bits may be greyed out or disabled to edit.

• Another way to modify a bit is to type the bit value directly to the New value [bin] / [hex] 
/ [dec] field.

You can view the binary format of signal values in a similar dialog.

Figure 59. Binary parameter editor
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Search for groups and parameters
You can search the names of parameters and groups inside the parameter window. The 
search result is a list of all parameters matching the search text criteria. For example, all 
torque-related parameters can be found by entering search criteria “torque” in the Enter 
keyword field and clicking the Filter check box. To uncheck the Filter box, click it again.

Figure 60. Search groups and parameters: example

Note: The first search takes about 30…60 seconds, because Drive composer goes 
through the whole parameter structure. The next searches are fast. All searches are in 
memory of the PC as long as Drive composer is on.
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Custom parameter window
In Drive composer you can customize parameter windows by:
• dragging and dropping parameters/signals

• changing parameter values

• copying from the main parameter window or from any other custom parameter window

• renaming custom parameter windows.

For example, you can 
• collect all the typical parameters used in a quick start-up to one window or

• create separate windows for separate functions (example: references, limits, ACS880 
I/O). 

 Custom parameter window features

The Custom parameter window 
• opens automatically when a connection to a drive is made because they are saved 

with the workplace.

• can be used both in tabbed and floating windows environment. 

• can also be opened separately.

 Saving custom parameter window

To save a separately opened custom parameter window to a file, select Save parameters 
to file. Note that changed values in the Offline value column are also saved. You can use 
the saved file for parameterization of another drive. You can also send this file to other 
users to open the file with Drive composer and view the parameters list.

Note: When you saved a custom parameter window, the actual drive values of the Value 
column are copied to the Offline value column. During loading, the values in the Offline 
value column are shown in comparison with the current actual values. From the saved 
customer parameter window file you can copy the values of the Offline value column to 
another drive by clicking the Download to device button.

Figure 61. Custom parameter window: Download to device button
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 Viewing copied parameter values 

In a network of drives, you can create a custom parameter window including 
parameters/signals selected from different drives. To have a view where all parameters 
are from one drive, click the Change drive button and select the drive.

To see the value of a parameter/signal used in another drive, right-click the 
parameter/signal and select Change drive.

Figure 62. Custom parameter window: Change drive 

 Adding parameters to a custom parameter window

The following example shows how to:
• create a new custom parameter window

• add parameters to a custom parameter window

• modify the Offline value column in the custom parameter window

• copy/download parameters to a drive.

1. Click File → New → Custom parameter set.

Figure 63. Custom parameter set
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2. Name the custom parameter window.

Figure 64. Custom parameter set: Name of window

3. Click Add button to add parameters/signals to the new custom parameter window or 
copy paste from other parameter window.

Figure 65. Custom parameter set: Add parameter

4. For example, select minimum and maximum speed values from the parameter group 
30 Limits and click Apply changes.

Figure 66. Custom parameter set: Add minimum and maximum values
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5. The Value column shows the values of connected drive. Enter values in the Offline 
value column to be same as Value column or you can type new values.

Figure 67. Custom parameter set: Change Offline values

6. Click on Save parameters to file icon to save the custom parameter window.

Figure 68. Custom parameter set: Save parameter to file

Drive composer saves to file the values in the Offline value column. If the Offline value 
column was empty, then values in the Values column is saved.

7. When connecting the next drive open the created custom parameter window by 
clicking File → Open → Custom parameter file.

You can now see the online values of the new drive.

8. Copy the offline parameter values to a new drive by clicking on Download to device 
icon.

Figure 69. Custom parameter set: Copy offline parameter values to a new drive
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Working with offline files

 Types of offline files

There are two types of offline files containing parameter information.
• Parameter file is an offline file containing all parameter values.

• Support package is an offline file package that contains a collection of drive 
information, including all parameter values. You can open a support package file 
using Drive composer pro. For further information on support package, see 
chapter Diagnostics on page 111.

 Saving parameters to a parameter file

1. Connect Drive composer to a drive and open the parameter window.

2. In the parameter window, click Save parameters to file icon.

Figure 70. Save parameters to file 

3. Select a folder, enter a name for the dcparamsbak file and click Save.

Figure 71. Save parameters to file: Save the dcparamsbak file
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 Opening a parameter file (entry)

To open a parameter file and view the parameter values offline, proceed as follows:

1. Connect to a drive.

2. Go to File → Open → Parameter file.

3. Parameter window displays.

 Opening an offline file containing parameter values (pro)

To open a file and view the parameter values offline, proceed as follows:

1. Connect to a drive.

2. Go to File → Open → Parameter file / Open Support package.

3. New item appears under File drives.

4. Select Parameters to open parameter window.

Figure 72. Opening an offline parameter file

Figure 73. Opening an offline parameter file from support package

 Downloading parameter values to a drive

Note: The operation do not perform full restore. Only visible parameters and ID run results 
are copied to a drive when the download command is used. Also, drive type and software 
version are not checked when downloading parameter values from an offline file to a drive. 
For further information on Restore function, see chapter Other functions on page 161. 

To download offline parameter values to a drive, proceed as follows:

1. Open an offline parameter window.

2. If you have multiple drives connected online, click Change drive to select a drive you 
want to download the parameters.

Figure 74. Downloading parameter values: Change drive
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3. Download the parameter values to a drive by clicking the Download to device icon.

Figure 75. Downloading parameter values: Download to device icon

4. If you get a message indicating that the upload of parameter values is going on, click 
OK.

     You will get a report of the operation at the end of the restore operation.

5. Check the parameters that are failed during the restore operation.

 Comparing drive data (pro)

Note: Both versions of Drive composer have Not at default function for listing user-
changed parameters. The Compare drive data function compares parameter values.

With Drive composer pro you can compare parameters between
• two drives

• two parameter files

• drive and parameter file.

1. Go to Tools → Compare drive data (Alt+C).

Figure 76. Comparing drive parameters

2. In a PC tool network, select drives from Drive A and Drive B drop-down menus.

3. To open a parameter file for comparison, click Open.

4. To see the parameter list without differences, deactivate Show differences check 
box.

5. Click Start compare.

Note: The operation may take some time to compare two different parameter 
structures.
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The following figure shows an example of the result.

Figure 77. Comparing drive parameters: Result of comparison

6. To export the result to a text (*.txt) file, click the Export.

Note: Click the >> << buttons to copy parameter values from Drive A to Drive B. 
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7

Monitor window

Contents of this chapter
This chapter describes the monitor window and its use.
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Monitor window overview
In Drive composer you can monitor the operation of connected drives. In the online mode, 
the monitor window shows signal values in graphical or numerical format. The monitor 
data can be saved to a file for later use.

With Drive composer entry you can monitor up to 8 signals.

With Drive composer pro you can monitor up to 26 signals. If Drive composer pro is used 
with an ACS880 drive, it is possible to monitor 1 signal per 1-ms time interval.

The monitor window is always a tabbed window, in other words, there is only one monitor 
window available.
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User-made monitoring settings (selected signals, y-scalings for signals, pen colors, 
number of grids etc.) are saved by default. In other words, when you open the tool, there 
are always the latest settings available.

 Resizing the monitor window

When you start Drive composer the monitor window is in the minimized position and you 
have to lift it in the following way before you can start monitoring.
• You can resize the monitor window by clicking the title bar with the primary mouse 

button and dragging it upwards.

Figure 78. Resizing monitor window
• You can resize the monitor window with the Minimize, Maximize and Split monitor 

buttons included in the Monitor menu bar.

• You can lift the monitor window by clicking the arrow buttons in the title bar.
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Adding parameters/signals for monitoring
There are two ways to add parameters/signals to the monitor window:
• Right-click a parameter/signal in the parameter window and select Send to monitor.

Figure 79. Monitor window: Send to monitor command
• Click the Add signal icon on the configurations and control area in the monitor 

window.

Figure 80. Monitor window: Configuration and control area icons

Select parameters from the Drive parameters list by double-clicking them or select a 
parameter and click Add button. You can add maximum of 26 parameters in Drive 
composer pro and eight parameters in Drive composer entry.

Note: 
• With Drive composer pro you can select signals/parameters from different drives. 

Change the drive from the Drive list as shown in the following figure.

• In the PC tool network via Ethernet or with a panelbus, ABB recommends you to 
select Disable polling to enable the best sampling result for monitoring. The 
status of the drive(s) cannot be read before you have unselected Disable polling.
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Figure 81. Monitor window: Drive list

The selected signals appear in the legend area.

To change the scalings of the y-axis of selected parameters/signals, click the Min or Max 
column in the legend area.

Active signals can be changed from the pull-down menu on the left side of the graph area.

All the other signal scalings are performed on the right side of the legend area. The right 
side y-scalings can be hidden by removing the check mark from the Y-scale column check 
box.

Figure 82. Monitor window: Changing pen color and style in the legend area

You can change the color and thickness of the pen only after you have minimized, that is 
hidden the legend area with the Arrow button on the left (see the figure above).

To change the scalings of the y-axis for selected parameters/signals, click the Min or Max 
column in the legend area.

 Monitor window components

The monitor window consists of the following parts:
• Configuration and control settings

• Graph area

• Y-axis

• X-axis

• Legend area

• Limit, color settings.
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Configuration and control settings

Icon Description

Opens the saved monitored file to the graph area, which can be done only after monitoring has 
been stopped. File extension is *.dcemon or *.dcpmon.

Note: If you have an online connection and want to start a new monitoring session after viewing 
opened monitored data, you can click the Monitor configuration icon.

Saves the accumulated monitor data to a monitored data file. File extension is *.dcemon for the 
entry version and *.dcpmon for the pro version.

Chart configuration can be used to set the colors for grids, number of grids, background color, 
color of alarm pen etc.

Opens the Monitor settings window where you can modify the monitor settings and the select the 
sample interval time for monitoring. You can also set the method for starting and/or stopping 
monitoring (by hand/time). You have to select the HD where the saved data is stored.

Note: The monitored data is saved cyclically to the selected file.

Created monitoring configuration can be saved and restored from Monitor settings window.

Allows you to create an arithmetic signal for monitoring by using two signals used in monitoring. 
Available operations are ADD, SUB, MUL and DIV.

Note: Remember to save settings in a workspace.

Opens a dialog where you can add or remove one signal or several signals from the monitor 
configuration.

Note: You can use the Add signal function only when monitoring has been stopped.

Shows the signal values in text format. Only the values seen in graph area are included in the 
numeric signal value list.

Copies the monitoring graph to a clipboard.

Scales the y-axis automatically.

Note: Zooming is not possible in the Autoscaling mode.

Resets both x- and y-axis zooming to original 100%.

You can export the monitored data in csv format to a PC. Exported data can analyzed with other 
tools. Use the Tab key for delimiting the columns.File extension is *.dcexp.

Aligns signals.

Selects or changes the drive.

Zooms in the x- and/or y-axis up to 1000%.
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Monitor controls

Active signal area overview
The Active signal area consists of functions that can be done with the selected active 
signal. The signal can be changed from the pull-down menu. 

Figure 83. Monitor window: Active signal area

The main functions are the following:

Figure 84. Monitor window: Measuring points for active signal

Icon Description

Starts recording data in the selected drives and displaying it on the screen.

Pauses monitoring on the screen but monitoring continues on the background. When you click 
the Pause icon again, all values are seen and monitoring continues normally.

Stops recording data in the selected drives. The graph or numerical values remain on the screen. 
The graph can be saved for later purposes.

Icon Description

Allows you to see the measuring points of the active signal. See figure Monitor window: 
Measuring points for active signal.

Note: This functionality works only if you have zoomed in enough in the graph area, that is, if the 
length of the x-axis is short enough.

Allows you to see the numeric values of the measuring points for the active signal. See figure 
Monitor window: Measuring points for active signal.

Note: This functionality works only if you have zoomed in enough in the graph area.

Searches to the left. The following search conditions can be selected from the 

pull-down menu: Above, Below or Either. See figure Monitor window: Search functionality.

Searches to the right. The following search conditions can be selected from the 

pull-down menu: Above, Below or Either. See figure Monitor window: Search functionality.
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Figure 85. Monitor window: Search functionality

Zooming the graph
To enlarge the graph and take a closer look at the details, follow these steps:

1. To set the starting corner for the enlargement, place the mouse cursor in the graph 
area and press down the primary mouse button.

2. Drag to the opposite desired corner, and release the button.

The part of the graph that was inside the selection rectangle zooms out to fill the graph 
area.

3. To reset the zoom tool, click the Reset zoom icon.

You can also use the zooming tool by selecting independent values from x and y pull-down 
menus.

Note: Monitoring is paused during zooming. To continue monitoring, click the Reset zoom 
icon shown in the figure below.

Figure 86. Monitor window: Zoom tool

Panning the graph
The graph can be panned by dragging the graph with the right mouse button pressed 
down.
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Legend area functions
The legend area shows selected signals. You can perform the following actions in the 
legend area:
• Change the color of the pen, thickness and style of the pen by minimizing the legend 

area and setting the values of each signal. See figure Monitor window: Legend area 
functions.

• Make signals visible or invisible by clicking the check box in the Visible column.

• Set a bit mask for monitoring. When you double-click the value in the Mask column, a 
new window opens allowing you to select bits for monitoring.

• Make Y-scalings visible or invisible by clicking the check box in the Y-scale column.

• Set values for y-axis scaling. You can modify the minimum and maximum values by 
clicking them and entering a new value. Press Enter to enforce the new value or press 
Esc to restore the value.

Note: If you do not see immediate changes in the graph area, check that autoscaling 
is not enabled.

• Set alarm limits for monitored signals. The color of a signal changes when the limit in 
the Alarm low or Alarm high column is reached. The color and style for the pen are 
selected from Chart settings.

• See the double cursor tool, y1 and y2 values and y2—y1 and x2—x1 differences.

Figure 87. Monitor window: Legend area functions
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Graph area functions
The monitor window and data logger window have similar graph area facilities for 
displaying signal values. Their usage is described here. Before Drive composer starts 
monitoring online, the OnLine monitor text is seen in the graph area. When monitor files 
are viewed, the DataFile Viewer text is seen in the monitor window.

The graph area shows the selected signal values with different colors. The x-axis 
represents Time and can be set from 1 to 120s. You can change the values in online 
monitoring mode. Scalings of the y-axis are changed in the legend area.

For data logger files, an orange arrow-head on the x-axis indicates where triggering has 
occurred. Data can be combined from several files to one graph.

 Double cursor tool

With the cursor tool, you can see the exact values of the signals at two positions in the 
graph area. You can move the position of cursors by clicking the primary mouse button 
down on the red cursor tool icon and moving it. While the mouse button is pressed down, 
you can move the cursor line to the left and right.

The time stamp of the cursor tool is shown in the header of the cursor tool. This is shown 
for the active signal. The time stamp changes if active signal is changed. The values for y1 
and y2 are shown in the legend area. Signal value differences are shown in the column 
y2—y1. The time difference for x2—x1 is also shown in the figure below.

Figure 88. Monitor window: Double cursor tool
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Workspace handling

Contents of this chapter
This chapter describes the workspace functionality.

See topics:
Workspace overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  103
Creating a workspace and using it as a default workspace. . . . . . . . . . . . . . . . . . . . . . . . . .  104

Workspace overview
Workspace consists of the user interface status, such as parameter windows and custom 
parameter windows.

The current workspace status can be saved to a file and restored later.

Note: 
• You cannot save/restore the following status data:

• drive control status

• If a drive has been controlled locally with Drive composer when the workspace is 
saved, the workspace is saved without the change in the drive control status.

• content, status and zooming levels of a stopped, paused or running monitor.

• Do not edit a workspace or graph file. The workspace (.dcxml) and monitored data 
(.dcmon) files can contain binary data. For example, if the default workspace file is 
corrupted, Drive composer does not open. If Drive composer does not open, delete 
your default (.dcxml) file from the PC and open Drive composer again.
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Creating a workspace and using it as a default workspace
1. Make a connection to a drive.

2. Resize the monitor window to half of the screen.

3. Create a new custom parameter window by clicking File → New.. → Custom 
parameter set and name it “Own limit window”.

Figure 89. Creating workspace: Custom parameter set

4. In the File menu, click Save workspace to save the workspace.

5. Create another custom parameter window and name it “Own reference window”.

6. Select floating windows by clicking View → Floating windows.

7. Enter keyword “Limit” in the Enter keyword field of the main parameter window.

8. Select parameters in the main parameter window and drag and drop or copy them to 
custom parameter window Limit.

9. Clear the search result and enter keyword “ref” in the Enter keyword field.

10. Select parameters in the main parameter window and drag and drop or copy them to 
custom parameter window Own reference window.

11. Close the main parameter window.

12. Click Event logger icon in the drive list on the left.
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13. Click File → Save workspace and name it “OwnWorkspaceFor_ACS880”. 

Figure 90. Creating workspace: Name your workspace

14. Close the connection to the drive and make a new connection.

15. Click File → Open.. → Open workspace and open the workplace that you have 
saved.
 

Figure 91. Creating workspace: Open workspace command

The workspace is ready to use for commissioning and maintaining drives.

The workspace can also be saved as a default workspace which opens automatically 
when Drive composer is started.
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Event logger

Contents of this chapter
This chapter describes the event logger and fault data logger view and its use.

See topics:
Event logger view  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  107
Fault data logger . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  109

Event logger view
The event logger view displays the event logs of a connected drive. The event logs can be 
faults (stopping the drive), alarms or events. With some drives there can be more data of a 
fault in the monitor window.

Note: Fault logger data can also be seen from other faults than the latest active faults.
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1. In the drive list, click on a connected drive and select Event logger. 

Figure 92. Event logger

The event logs of the connected drive appears in a separate tab.

Figure 93. Event logger view

The event logger always relates to a single drive and resides in its window.

The Icon column shows the following alarm and fault icons:

Icon Indicates

Red circle with white cross (x)
drive has a fault

Yellow triangle with exclamation mark (!)

drive has an alarm

 or  Grey circle/triangle

fault or alarm has disappeared from the drive
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The time stamp for faults, alarms and events comes from the drive.

You can view the sorted list of faults, alarms and events by clicking the header of the Fault 
column.

Fault data logger

The Fault data icon  in the Event logger view shows that the drive has fault data that 
can be seen with a monitor component. The icon is visible only if the drive sports the 
functionality.

1. In the Event logger window, click on the  icon.

The message “Please wait. Loading fault data” appears. The data is loaded after the 
message box disappears.

Figure 94. Fault data logger in the monitor window

2. When Drive composer prompts to save the fault data, click Yes.

3. Give a file name for the monitor file. 

The file is saved with .dcpmon extension.

Note: You can continue the normal monitoring by clicking the Monitor configuration  
icon in the Monitor controls box of the Data Logger window.

The message “This operation will change monitor into measuring mode and restore the 
last used configuration. Data on display will be lost. Do you want to continue” appears.
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If you clicked Yes, the monitor settings window appears. Select necessary settings and 
click OK.

Figure 95. Event logger: Monitor settings window
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Diagnostics

Contents of this chapter
This chapter describes how to troubleshoot a drive with the Support package button of 
Drive composer and a Datalogger included in the drive. It also includes how to register an 
ABB drive to the Drive Installed Base (DIB) portal and create service reports.

See topics:
Support package . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  112

Creating a support package . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112
Opening a support package (pro). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112

Drive application programming license . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  113
System info . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  113
Datalogger (pro)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  114

Datalogger settings. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 116
Adding a trigger  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118
Uploading triggered or stopped Datalogger data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119

Amplitude logger (pro) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  121
Using DIB service  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  122

Registering an ABB drive to DIB service  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122
Searching a registered ABB drive in DIB . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Setting the DIB server location . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
Creating a service report from DIB . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 130
Create online service report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 131
Creating offline report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136

Macro (pro)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  137
Macro commands  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  138

Macro language . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 138
Additional macro commands  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139
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Support package
Support package is an offline package file that contains, for example, full parameter 
backup, system information, and event logger contents. The main purpose is to collect 
troubleshooting data and send it to the support personnel for analysis.

 Creating a support package

By clicking the Support package button, you can create and save a support package file.

Figure 96. Support package button

 Opening a support package (pro)

You can open Support package file in Drive composer pro by selecting File → Open → 
Open support package, a new File drive appears. There is similar menu available with 
online drives.

For further information on each module, see section System info on page 113, chapters 
Parameter window on page 71 and Event logger on page 107.
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Drive application programming license
The drive application programming license N8010 is required for downloading and 
executing the program code on the ACS880 drive. In DriveComposerPro, select System 
info tab. Check if the appropriate license is loaded to the drive. If the required license code 
is not available, contact your local ABB representative.

Figure 97. System info command

System info
The System info tab provides basic information about the drive and its options, for 
example, drive type code and firmware version.

Figure 98. System info

You can also set the time for the drive and name the drive.
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Datalogger (pro)
ABB drives have Datalogger(s) that can record data from various signals of a drive even if 
the drive is not connected to a PC. A Datalogger is operated with the Datalogger view.

Figure 99. Datalogger configuration

The data collecting can be stopped with a specific stop command or automatically when a 
triggering condition is true in the drive. After data collection stops you can read and study 
the data in Drive composer pro.
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The Datalogger view resembles the monitor window. Normally the Datalogger view 
provides data from a single drive.

Figure 100. Datalogger view
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 Datalogger settings

The Datalogger settings window contains the following functions:
• Datalogger commands

• Datalogger content configuration

• Datalogger trigger configuration

Datalogger commands

Datalogger content configuration

With the Datalogger content configuration you can determine which Datalogger of a drive 
is used.

Figure 101. Datalogger content configuration

Button Description

Start button records data in the current logger of the drive until Datalogger is triggered or 
stopped.

Stop button ends recording immediately without any post trigger recording.

Trigger button triggers the associated logger in the drive. Trigger Datalogger is displayed in 
Datalogger status with trigger code 15.

Upload button moves data from the drive to PC and draws it to the monitor window. Datalogger 
replaces any previous data in monitor window.

Apply button applies monitored signal and Datalogger sampling settings.

Datalogger configuration 
commands

Function

Logger Determines which logger settings are modified. A drive has user logger(s) 
and factory logger(s). Factory logger settings cannot be modified.

Sampling interval Determines in microseconds how often the logger reads samples of the 
signal values. The time level shows the available lengths of the internal 
cycle time of the drive. Sample interval is formed from multiplier (1-65535) 
and time level selection.
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To add parameters to the logger, proceed as follows:

1. In the Datalogger screen, click  to add parameters.

2. Select a parameter in the Drive parameters list and double-click or click Add. The 
parameter is added to Selected parameters.

Figure 102. Parameter window

Note: The maximum number of signals that a logger can record at one time depends on 
the drive. Add button is disabled when maximum number of parameters are reached. 

3. To remove the parameter from Selected parameters, select the desired parameter and 
click Remove.

4. Click Apply changes after making the changes.

Post trigger count Specifies how many samples are stored after the triggering condition 
occurs when the value is smaller than Datalogger total space count. The 
Datalogger total space count depends on drive type, selected signal types 
and total signal count. If the post trigger count value is bigger than 
Datalogger total space count, the triggering point is not visible anymore in 
the Datalogger.

Sampling time Shows the minimum sampling time with a selected number of signals and a 
selected sample interval.

Logger signals panel Shows a list of signals selected to record. You can add/remove a signal by 
clicking the Add signal icon.

Datalogger configuration 
commands

Function



118   Diagnostics
Datalogger trigger configuration

Datalogger has four triggers that can be configured to stop the Datalogger. After 
Datalogger has triggered, the Datalogger samples post trigger the amount of new 
samples.

Figure 103. Datalogger trigger configuration

 Adding a trigger

1. To modify the conditions of a trigger, select the trigger from the Trigger drop-down 
menu.

Trigger 1 is normally used for user logger 1, Trigger 2 for user logger 2 etc.

2. Choose the type for the triggering condition from the Type drop-down menu.

Following are the alternatives (however, not all of them are available at all times):
• Bit mask stops according to the bit mask of the selected signal.

• Disabled can temporarily disable a trigger condition.

• Falling edge level stops according to the selected signal, triggering level and 
hysteresis values.

• Fault stops when the drive reports a fault.

• Event stops when the drive reports an event.

• Rising edge level stops according to the selected signal, triggering level and 
hysteresis values.

• Warning stops when the drive reports a warning.

3. If you use Rising edge level or Falling edge level as the type for the triggering 
condition, see Using the level triggers.

4. Click Apply.
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Using the level triggers

When condition Rising edge level is used, the function wakes up when the actual value of 
the triggering signal is below the triggering level - hysteresis. Similarly, when condition 
Falling edge level is used, the function wakes up when the actual value of the triggering 
signal is above the triggering level + hysteresis.

Using bit mask trigger

Bit mask trigger reads signal value and masks out user selected bits with given mask. 
Masking is done by using a logical AND operation. Masked value is compared to user 
given bit values selection. When masked value and bit values match, Datalogger is 
triggered.

 Uploading triggered or stopped Datalogger data

1. In the Datalogger view select a logger from the Logger drop-down menu.

If the logger status is stopped or triggered, data can be uploaded.

2. Click Upload to upload data to the monitor window.

Note: If you want to continue normal monitoring after using the Datalogger, click 
Monitor configuration icon and select a sampling interval for monitoring.

Figure 104. Continue monitoring after using the Datalogger

Rising edge Triggering signal is below the triggering level when the Datalogger is started:
Triggering occurs when the signal goes above the triggering level.

Triggering signal is above the triggering level when the Datalogger is started:
Triggering occurs when the signal goes above the triggering level, but before that the signal 
must go below the triggering level - hysteresis.

Falling edge Triggering signal is above the triggering level when the Datalogger is started:
Triggering occurs when the signal goes below the triggering level.

Triggering signal is below the triggering level when the Datalogger is started:
Triggering occurs when the signal goes below the triggering level, but before that the signal 
must go above the triggering level + hysteresis.
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3. Click Add signal icon to add signals for monitoring.

Figure 105. Uploaded Datalogger data
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Amplitude logger (pro)

ABB drives have an amplitude loggers that can record data from various signals of a drive. 
The results of an amplitude logger 1 (current) are displayed by the following curve. Each 
parameter represents an amplitude range and shows what portion of the samples fall 
within that range.

Note: Dataloggers or amplitude loggers are not available for all ABB drives.

Figure 106. Amplitude logger
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Using DIB service 
Drive installed base (DIB) is a knowledge base for all information about drives. Using DIB 
service you can,
• register an ABB drive through Drive composer (see page 122)

• obtain the required drive information (see page 127)

• create service reports (see page 130).

 Registering an ABB drive to DIB service

1. From the drive context menu select Register drive, or go to Tools → Register drive.

Figure 107. Register drive

If you used the drive context menu, make sure that drive composer is connected 
online with the drive for successfully registering the drive. If you used Tools → 
Register drive, you can register the drive when drive composer is either in 
online/offline mode with the drive.

2. In the Drive registration tab, type the drive serial number (for example, 32400110) and 
click Validate. You can see the drive serial number on the type designation label or 
see the drive’s hardware manual for more information.

Figure 108. Register drive: Drive serial number
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Drive composer connects to DIB portal (external website) and validates the serial 
number with an associated type code. If the number is valid, the drive type code is 
automatically filled. For example, PCB, CT BOARD. 

Figure 109. Register drive: Drive type code

Note: You can register a serial number for first-time only. If attempted second time, the 
message “This serial number has been already registered” is displayed.
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3. Enter drive location details in the appropriate fields.

Figure 110. Register drive: Drive location details

Field name Information

Site country Name of country where the drive is located, for example, India.

Company name Name of company where the drive is located. For example, ABB India.

Site name Site name where the drive is located.

Site city, Site postal code Name of city and postal code where the drive is located. 

Site address Site address.

Plant/Building, 
Area/Room

Optional. Plant /building name and area/room where the drive is located.
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4. Type name and email address of the drive owner or the contact person details. Phone 
number is optional.

Figure 111. Register drive: Drive owner details

5. Type/select drive information in the appropriate fields.

Figure 112. Register drive: Drive information
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6. Check and accept the Terms and conditions, and click Next. 

7. Check the summary of registered information and click Save.

Figure 113. Registering drive completed

The “Registration was completed successfully” message is displayed. You will also 
receive an email to the registered email address

Field name Information

Customer equipment id for the Drive Optional. Customer identification of drive, if available.

Commissioning start up date Drive commissioned startup date. 

Application Application where the drive is used (for example, Spinning).

Criticality in process Criticality of the application based on the time required to stop the drive 
in the event of a fault.

Low - No direct impact

Medium - Delayed stop

High - Immediate stop

Industry Industry where the application is in use.
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 Searching a registered ABB drive in DIB

You can search for information about an ABB drive that is registered in DIB service portal. 
Note: Make sure you have access permissions to DIB service portal.

1. From drive context menu select Search drive from DIB or go to Tools → Search 
drive from DIB.

Figure 114. Search drive from DIB
• If you used the drive context menu, Drive composer extracts the drive serial 

number directly from the connected drive. Otherwise the “Drive has not got serial 
number” message is displayed.

• If you used Tools → Search drive from DIB, Drive composer asks for serial 
number. 

2. Type the serial number and click Ok.

Figure 115. Search drive from DIB: enter serial number
• If the serial number matches with the drive data in DIB, Drive composer 

downloads all data related to the drive and opens in a separate tab. 

Figure 116. Search a drive from DIB: Product info tab
• If you typed a wrong serial number or if the drive was not registered in DIB, the 

message ..... “Authorization failed, do you want to log in again” or “Drive has not 
got serial number” is displayed. 

3. Click Product info, to view the drive information, for example, serial number, type 
code, commissioning date, etc.
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4. Click Service history, to view the maintenance history of the drive, for example, event 
or service type, date of service, name of service engineer, etc. You can download the 
attached service report file, if the file was added to the report.

Figure 117. Search drive in DIB: Service history tab

5. Click Recommended services, to view the recommended drive services. 

Figure 118. Search drive in DIB: Recommended services

6. Click Components, to view the details of service components. 

Figure 119. Search drive from DIB: Components tab
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 Setting the DIB server location

The drive data is stored only in two server locations: Europe and China. The default 
location is Europe. For drives located in China, select China and for drives located in 
countries other than China, select Europe.

1. Go to View → Settings.

2. In the Settings window, select the appropriate DIB server location. Example: Europe.

Figure 120. Settings: Use DIB server location

3. Click Save.

The DIB server location is set to the selected country.
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 Creating a service report from DIB 

You can create a service report for an ABB drive registered in DIB, if you have access 
permissions to the DIB portal.

Note: The service report templates are predefined. However, if it is necessary to change 
the template, contact your local ABB representative. 

1. Click on the drive list, select Create service report or go to Tools → Create service 
report.

Figure 121. Create service report from DIB

2. In the Service reporting page, click Select. 

Figure 122. Service report page: Select drive serial number
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3. Select the appropriate drive. Click Ok.

Figure 123. Service report page: Select drive type

4. In the Service reporting page, type the drive serial number. 

5. In Select service type field, select the necessary service type, for example, ACS880-
01 Cooling fault - Code 4290.

Note: Drive composer downloads the selected service type. If downloading failed due 
to network error, you can use the previously downloaded service package. 

6. If the registered drive serial number and service type matched with the DIB data, you 
can Create online service report or Creating offline report. See sections below. 

 Create online service report 

Note: The contents in the report page are based on the service type and some contents in 
the wizard may be filled with information from the drive if the serial number matched with 
the drive.

In the below steps, see an example report of ACS880-01 Cooling fault.

1. In the service report page, click Report online. 

Figure 124. Create online service report: Report online

2. In the Sending to DIB message box, click Yes, to proceed with the next steps or click 
No, to stop the process and do the necessary changes to the location settings. See 
section Setting the DIB server location. 

Figure 125. Sending report to DIB
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3. In the General Info page with already filled drive serial number and type code, fill other 
necessary information. Click Next.

Note: All mandatory fields in this page and in the consecutive pages appears in a red 
border and an asterisk (*). 

Figure 126. Create service report: General Info page

4. In the End customer page, type details of location where the drive is installed. Click 
Next.

Figure 127. Create service report: End customer page
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5. In the Fault page, select the appropriate date when the fault occurred. You can update 
information of up to four fault codes. Click Next.

Figure 128. Create service report: Fault Info page
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6. In the Onsite check list, check and confirm that all actions are completed. All actions in 
this list are mandatory. Click Next.

Figure 129. Create service report: Onsite checklist page

7. The consecutive pages for Material data are optional. You can fill up to five material 
data. Type the information if necessary and click Next.

Figure 130. Create service report: Material Info page
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8. In the Components list, confirm that the listed components are available in the drive. 
Check against the listed component to report to DIB service. Click Send.

Figure 131. Create service report: Components list 

Drive composer sends the filled-in report to DIB service portal. Click Ok.

Figure 132. Create service report: Sending report to DIB completed

If the report sending failed, Drive composer prompts to save the report in Offline reports, 
which you can try sending later. See Creating offline report.
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 Creating offline report

Note: The contents in the report are based on the service type and some contents in the 
wizard may be filled with information from the drive if the serial number matched with the 
drive.

1. In the service reporting page, click Create offline report.

Figure 133. Create offline report

A service report is generated and appears in the Offline reports table.

2. Select the report and do the necessary actions:
• Click Edit, if it is necessary to modify the report. See section Create online service 

report (step 3 onwards).

• Click Send, if the report is ready to send to DIB. In the message box, click Yes to 
send the report. Click No, if you want to change the server location. See section 
Setting the DIB server location.

Figure 134. Sending offline report to DIB
• Click Remove, to delete a report. Confirm the message “The offline report has not 

been sent to DIB. Are you sure you want to remove it and lose all changes?” 

 



Diagnostics   137
Macro (pro)
ABB drives have Macro functionality that can automatize a task or sequence of tasks. 
Macros are used for parameter value setting to multiple networked drives when custom 
window functionality is not sufficient. Macros may also be used for tasks which require 
logical or conditional parameterization of a drive.
• In the main menu, click Tools and select Macro.

Figure 135. Macro command

A Macro screen is displayed.

Figure 136. Macro 
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Macro commands

 Macro language

Macro language is based on PAWN. For general programming guidelines, refer to PAWN 
manual. 

Note: Some PAWN features are disabled for security reasons, such as file operations and 
other external IO functions.

Simple example

Macro tries to read parameter 1.1 value from each target in 100 network channels.

main()

{

    for(new i = 0; i < 100; i++)

    {

        //note the channels are indexed instead of nodes

        // this should be modified according network topology

        //change target

        Target(i+1,1)

        new targetName[100]

        //get target name

        TargetName (targetName)

        //read parameter 1.1 value

        new Float:val0101 = ParRead(1,1);

        //output to console

        printf "%s(%d,%d): %f\n", targetName, 1, 1, val0101 ;

    }

}
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 Additional macro commands

Target

Changes the target of the macro command after target command is issued.

Target name

Command reads the current target name as string.

ParWrite

Command writes parameter value to current target.

Note: The command does not write pointer or bit pointer type parameter values. Use the 
ParWriteInt command to write pointer or bit pointer type parameter values.

ParWriteInt

Command writes parameter value to current target.

Syntax Returns Example

Target (Channel, node) 0 if success, 1 if failed Target (1, 10)

Syntax Returns Example

TargetName (string) 0 if success, 1 if failed //reserve name string

new name[100]

if(TargetName(name)==0)

{

printf "target name is %s\n" name

}

Syntax Returns Example

ParWrite (group, index, value) 0 if success, 1 if failed //write value 1 to group 12 index 16

main ()

{

ParWrite (12, 16, 1)

}

Syntax Returns Example

ParWriteInt (group, index, value) 0 if success, 1 if failed.

If an error was 
detected, the error 
message appears in 
the log.

//write value 1 to the parameter in group 12 
index 16

main ()

{

ParWriteInt (12, 16, 1)

}
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ParRead

Command reads the parameter value to current target.

Note: The command does not read pointer or bit pointer type parameter values. Use the 
ParReadInt command to read pointer or bit pointer type parameter values..

ParReadInt

Command reads parameter value to current target from the same source as in the 
parameters window. The values are cached and refreshed on a notification or every half a 
second, if you selected the Enable updating option in the parameters window. When real 
time values are required, you can use the command ParReadIntFromDevice.

Syntax Returns Example

ParRead (group, index) Parameter value or 0 if failed.

If an error is detected, the 
error message appears in the 
log.

//Read value of the parameter in 
group 10 index 5

main ()

{

new Float.val = 
ParRead(10,5);

printf “Value of (%d,%d): 
%f\n”, 10,5, val105;

}

Syntax Returns Example

ParReadInt (group, index) Parameter value casted to 
integer or 0 if failed.

If an error is detected, the error 
message appears in the log.

//Read value of the parameter in 
group 7 index 11

main ()

{

new val = ParReadInt (7,11);

printf “Value of (%d, %d) : 
%d\n”, 7,11, val;

}



Diagnostics   141
ParReadFromDevice

Command reads the parameter value to current target directly from drive.

ParReadIntFromDevice

Command reads the parameter value to current target directly from the drive.

Wait

Command delays the macro execution for given time in milliseconds.

Syntax Returns Example

ParReadFromDevice (group, 
index)

Parameter value or 0 if failed.

If an error is detected, the error 
message appears in the log.

//Read value of the parameter in 
group 1 index 11 each second.

main()

{

new Float:val;

do

{

val = ParReadFromDevice(1, 
11);

printf "Value of 
(%d,%d):%f\n", 1, 11, val;

Wait(1000);

}

while (1);

}

Syntax Returns Example

ParReadIntFromDevice 
(group, index)

Parameter value casted to 
integer or 0 if failed.

If an error is detected, the 
error message appears in the 
log.

//Read value of the parameter in group 7 
index 11 each second.

main()

{

new val;

do

{

val = ParReadIntFromDevice(7, 
11);

printf "Value of (%d,%d):%d\n", 
7, 11, val;

Wait(1000);

}

while (1);

}

Syntax Returns Example

Wait (milliseconds) 0 in all cases //wait 0.1 seconds

Wait(100)
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EndMacro

Command ends the macro execution.

GotoMacro

Command changes the macro execution. Currently running macro execution is 
terminated.

MessageBox

Command shows message box with ok button.

Syntax Returns Example

EndMacro() 0 in all cases //End execution

EndMacro()

Syntax Returns Example

GotoMacro(string) 0 in all cases //Change execution to macro jeejee

new macrofilename[100]

macrofilename = “jeejee.p”

GotoMacro(macrofilename)

Syntax Returns Example

MessageBox (string) 0 in all cases //show messagebox

new message[100]

message = "dingalongdangdong"

MessageBox (message)
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Control diagrams (pro)

Contents this chapter
This chapter describes the use of control diagrams that help in understanding the behavior 
of a drive.

See topics:
Control diagrams overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  143
Viewing control diagrams . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  144

Control diagrams overview
Control diagrams provide a graphical presentation of, for example, the control chain of a 
drive, the speed and torque control chains and the logic of Start and Stop functions. With 
these diagrams it is possible to see parameter values related to certain functions. 
Diagrams also illustrate the position of switches according to parameter values, which 
helps to understand how the drive logic works. The values of parameters can be changed 
via control diagrams. A control diagram consists of two levels. The top level shows an 
overview of the diagrams and connections between them.

Note: 
• Control Diagrams are drive-specific and they are not available for all drive types.

• When you connect a drive for the first time, it takes sometime to upload control 
diagrams from the drive. If Control Diagrams are not found in the drive, Drive 
composer asks to upload diagrams from the local source (PC).
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Viewing control diagrams
1. In the drive list, click on a connected drive and select Diagrams. 

Figure 137. Control diagrams: Selecting from the drive tree

2. The top level of a control diagram consists of several diagrams and appears in a 
separate tab. See the example screen below. To open a specific diagram, click on a 
top level control diagram box. 

Figure 138. Control diagrams: Top level 
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The lower level control diagram appears in a separate tab. See the example diagram 
below.

Figure 139. Control diagrams: Lower level

To navigate back to the top level of a Control Diagram, click the Diagrams top icon. To 
navigate through the reference chain, click the buttons circled in the figure above.

To zoom the control diagrams, use the zooming tool in the top left-hand corner of a Control 
Diagram.

Figure 140. Control diagrams: Zooming tool
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FSO configuration (pro)

Contents of this chapter
This chapter contains the configuration procedure of FSO-12 and FSO-21 safety functions 
with Drive composer pro and provides an example of how to configure these optional FSO 
safety functions modules.

See topics:
Configuring FSO-12 and FSO-21 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  147

Hardware connection. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148
Setting the safety functions with Drive composer pro . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148
Printing the safety functions configuration report (Online). . . . . . . . . . . . . . . . . . . . . . . . . . . . 155
Printing the safety functions configuration report (Offline). . . . . . . . . . . . . . . . . . . . . . . . . . . . 159

Configuring FSO-12 and FSO-21
The safety configuration of FSO-12 and FSO-21 safety functions module is available only 
in Drive composer pro, DCPT-01 (code: 3AUA0000108087). 

Note: 
• Only trained persons are allowed to configure the safety functions. 

• Stop the drive before configuring the safety functions modules. You cannot 
download/upload the configuration file to/from safety functions module or change 
the password when the drive is modulating.

• You need a password to copy the configuration to the safety functions and also to 
validate the safety parameter settings. 

• You can open a dcsafety file in Demo mode of Drive composer pro.
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For detailed information about FSO-12 and FSO-21, see the respective safety functions 
module user’s manual:

• FSO-12 safety functions module user’s manual (3AXD50000015612 [English]).

• FSO-21 safety functions module user’s manual (3AXD50000015614) [English]).

 Hardware connection

The hardware connection is common for both FSO-12 and FSO-21 safety functions 
module. For instructions on the hardware connections, see FSO-12 safety functions 
module user’s manual (3AXD50000015612 [English])/ FSO-21 safety functions module 
user’s manual (3AXD50000015614 [English]). 

The following configuration description assumes that all hardware-related connections are 
made properly and the ID run procedure of the drive is completed.

 Setting the safety functions with Drive composer pro

WARNING! The motor must be stopped. Safety configuration file can be edited (and 
sanity checked) in demo mode for offline configuration. Edit and save the file to PC 
without connecting to the drive/FSO.

1. Power up the drive. Make sure that the motor is not running. 

See Working area on page 69.

2. Right-click on drive and select Safety settings. 

Figure 141. FSO configuration: Selecting safety settings with FSO module
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In online mode with FSO installed, the safety configuration already available in the drive is 
displayed (see figure below). In offline mode the view is always empty before opening the 
safety file.

You can switch between Graphical view and Parameter view. See Figure 142.FSO 
configuration: Graphical view and Figure 143.FSO configuration: Parameter view.

Figure 142. FSO configuration: Graphical view

Figure 143. FSO configuration: Parameter view
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3. Click Read settings from drive.

Note: When you upload the safety settings from FSO module to PC tool, the FSO 
goes into Configuration state and indicates a fault. You can exit the Configuration state 
by rebooting the FSO module if you do not want to download the settings but want to 
keep the existing setting. 

The Fault FSO general fault: 7A8B appears on the drive.

Figure 144. FSO configuration: FSO general fault due to configuration state

4. Type the password (8 numbers). The factory default password is “12345678”.

Figure 145. FSO configuration: Enter password

Note: You can change password by clicking Change password (see figure FSO 
configuration: Parameter view). Make sure the drive is not modulating. The password 
must contain 4…8 digits. Do not forget the new password; otherwise you have to do a 
factory reset to the FSO which clears the configuration and resets the parameters to 
the factory defaults.

5. Configure the safety parameters. Set the following safety function parameters:
• General parameters: Check that the motor parameters are correct.

• I/O: Check that I/O parameters are set according to the installation (wiring) plan. 
Remove diagnostic pulsing from any unused I/O. The test pulses are off by 
default. Check possible safety relays and cascade connections.

• Safety functions: Check all safety settings. You must at least check and set the 
STO and SSE related settings, regardless of whichever FSO safety functions you 
use. The FSO activates the STO and SSE functions (also in internal fault 
situations). The FSO uses the STO and SSE functions for making the system 
safe. All other functions are used only for monitoring the drive.

Notes: 
• Graphical view cannot be used for setting safe IO, cascade function or for SBC 

function (see Figure 142.FSO configuration: Graphical view). Instead use the 
Parameter view (see Figure 143.FSO configuration: Parameter view).

• Parameter groups (200, 91 and 92) that include common parameters to drive and 
FSO are referred with group numbers and index numbers.

• Group names like FSOGEN, STO and so on have only index numbers (see Figure 
149.FSO configuration: Edit parameters). 

For examples of configuration settings and list of group names, see FSO safety 
functions module User’s manual.
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6. In graphical view, double-click a function or the General settings tile to activate the 
safety function and open the general settings.

Note: You can view the filtered tiles view with the Filter functions by setups. Click 
one of these filtering options to filter other tiles away from the view.

Figure 146. FSO configuration: Filter function in graphical view

7. In the opened tile view, configure the function or general settings group by editing all 
necessary parameters. 

Figure 147. FSO configuration: Configure function or general settings group

After editing is completed, click Done to close or to stop editing. Click Reset if you 
want to reset to default. 

Note: In Graphical view the SAR settings are combined with safety function 
parameters. Using the reset option for parameters that are used crosswise (e.g. SAR1 
is used with SS1 and SLS functions) resets the particular settings for both functions. 
The function works the same in parameter view in which the parameters are in 
separate groups.
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8. In the Graphical view, enable/disable the function or general settings group using the 
slider switch. 

Figure 148. FSO configuration: Enable/disable function

9. In Parameter view, double-click on the value field and change all necessary 
configuration settings to match the safety configuration.

Figure 149. FSO configuration: Edit parameters

10. Test your safety configuration when the motor is running.

Slider switch enabled

Slider switch disabled
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11. Right-click on drive and select Parameters to check the values in parameter 
group 200. 

You can also validate the safety function parameters using the signal monitoring 
feature. See the instructions for Adding parameters/signals for monitoring. It is 
possible to check the ramp times and the status of bit changes in the time domain. 

Figure 150. FSO configuration: Parameter group 200

12. Check the values in online mode while testing the safety functions.

If there are unexpected values, right-click the parameter and select Refresh the 
parameter.
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13. After testing save the FSO configuration to PC. In Parameter view, click Save to file.

Figure 151. FSO configuration: Saving the safety settings

The file is saved as dcsafety format and the File written successfully dialog appears. 
Click Ok.

14. Click Apply settings to drive. 

15. Enter the password to apply the settings to the drive and click Ok.

The following Validate dialog appears. Click Yes.

Figure 152. FSO configuration: Validate dialog

Note: If you do not want to download the changes in safety parameters, you can boot 
FSO without downloading to FSO using Reboot FSO (see figure FSO configuration: 
Saving the safety settings).

16. Click Ok to close the dialogs.

Figure 153. FSO configuration: Safety configuration ok message
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 Printing the safety functions configuration report (Online)

With the FSO module installed, you can print the online safety functions configuration 
report. 

1. From the Safety settings view, click Print report.

Figure 154. Safety configuration report: Print Report

2. Select a print template and click Continue.

Figure 155. Safety configuration report: Select print template

3. Fill in the Drive and FSO version information. Click Next.

Figure 156. Safety configuration report: Drive and FSO information



156   FSO configuration (pro)
The next screen(s) contain different aspects of safety configuration such as configured 
safety functions, commissioning checklist, and so on. 

The List of configured safety functions and acknowledged methods appears. Click Next.

Figure 157. Safety configuration report: List of configured safety functions 

In the FSO commissioning checklist, click on the check boxes to mark configurations are 
ok. Click Next.

Figure 158. Safety configuration report: FSO commissioning check list
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In the FSO changes/repair details, type the required details and click Next.

Figure 159. Safety configuration report: FSO changes/repair

4. In the final screen fill in the required details and click Print preview. 

Figure 160. Safety configuration report: Print preview 
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5. Select the required printer settings and click Print.

Figure 161. Safety configuration report: Printer settings

The configuration and commissioning report is printed based on the selected printer 
settings.
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 Printing the safety functions configuration report (Offline)

To print a FSO safety functions configuration report in the Offline mode, you must have a 
saved safety file. See section Setting the safety functions with Drive composer pro (page 
148).

1. Click Tools → Safety Configuration Report.

Figure 162. Print safety configuration report: Tools menu

2. Select the saved file to print and click Continue.

Figure 163. Print safety configuration report: Select print template 

Continue from step 3 in section Printing the safety functions configuration report (Online), 
page 155. 



160   FSO configuration (pro)



Other functions   161
13

Other functions

Contents of this chapter
This chapter describes common functions that are not associated with any view or 
window. 

See topics:
Creating a backup of a drive. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  162
Creating a backup in drive parameter view  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  163
Restoring a drive. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  163
Restoring a backup in the drive parameter view. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  164
Restoring a set of components/parameters settings (pro) . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  164
Using the Localization editor. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  166
Using the Drive parameter conversion tool (pro)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  168
Using the PSL2 data logger (pro) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  171

Uploading PSL2 data logger files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 171
Using the PSL2 data viewer (pro). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  173

Viewing PSL2 data logger files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 173
PSL2 Data Viewer instructions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 173

Adaptive programming . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  175
Locking user interface. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  176

Lock state in System info page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 176
Lock state in parameter view. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 176
Lock state in Backup/Restore page. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 177
Lock state in Safety settings page (pro)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 178
Lock state in Localization editor (pro)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 179
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Creating a backup of a drive
1. Click on a connected drive and select Backup/restore.

Figure 164. Backup command

2. Select the file location for the backup and give a name for the backup file.

Figure 165. Backup/restore: select backup file location

3. Click Backup to start the backup process.

The backup process takes a few minutes.

You can also create a backup in the drive parameter view. See Creating a backup in drive 
parameter view.
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Creating a backup in drive parameter view
1. In the parameters view, click on Save parameters to file icon.

Figure 166. Create backup in drive parameter view

2. Select a file location in your computer for the backup and give backup file name. Click 
Save.

The backup process takes a few minutes.

Restoring a drive
1. Click on a connected drive and select Backup/restore.

Figure 167. Restore command

2. Select the backup file to restore to the drive.

Figure 168. Backup/restore: select restored backup file location
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3. Click Restore.

All available components are restored from the backup file and all unavailable 
components are preserved in the drive.

Restoring a backup in the drive parameter view
1. Open a parameter backup file. Click Download to device icon.

Figure 169. Backup/restore: Restore in drive parameter view

All available components are restored from the backup file and all unavailable components 
are preserved in the drive.

Restoring a set of components/parameters settings (pro)
1. Click on a connected drive and select Backup/restore.

Figure 170. Restore command

2. Click Advanced restore to select a restored backup file.

Figure 171. Backup/restore: Advanced restore
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3. Select a saved backup file and click Open.

4. In All Items, select a set of components/parameter settings to be restored to the drive. 
Click right arrow (>>) to move the selected components to Selected items.

5. Click Restore below Selected items. 

All selected components are restored from the backup file and all the not selected 
components are preserved in the drive.

Note: 
• The parameter values that are not written to the drive are listed in the restore 

report after the restore process.

• The drive does not allow to restore the grey items in the advanced list.
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Using the Localization editor
You can manage user editable texts using the Localization editor. The function allows to 
read texts from drive, to make changes and to update texts to the drive.

1. Select Tools → Localization Editor.

Figure 172. Localization editor

2. Select the drive to work with and click Ok.

Figure 173. Localization editor: select drive

The Localization editor is started and attached to the selected drive.

3. Read and make changes in the column Localized text. If you changed any text, click 
Apply.

Figure 174. Localization editor: Localized text
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The changes are written to device and Download finished successfully message 
appears.

4. Click Ok.
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Using the Drive parameter conversion tool (pro)
The parameter files of ACS800/ACS600 ABB drive types commissioned and maintained 
with DriveWindow can be accessed with Drive composer via the Drive parameter 
conversion tool.

Note: Not all ACS800/ACS600 drives and software are supported.

1. Go to Tools → Drive parameter conversion tool.

Figure 175. Drive parameter conversion tool

2. In the Drive Parameter Conversion Introduction screen, click Next.

Figure 176. Drive parameter conversion: Introduction
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3. Browse and select appropriate source and destination drive parameter files. 

Figure 177. Drive parameter conversion: Browsing the source and destination drive file

Note: Select an empty parameter file with default values. You must create an offline 
parameter file (of the destination drive family) to select here.

4. Select a file name to save the target file. Click Next.

Note: Do not overwrite the empty file.

5. Answer Yes.



170   Other functions
The Conversion report shows the parameters which are converted successfully and 
failed. Read the report carefully and fix the parameter values manually for which the 
conversion was not successful. 

Figure 178. Drive parameter conversion: Results 
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Using the PSL2 data logger (pro)
With BCU-x2 control unit, you can upload the PSL2 data logger files from the drive flash 
memory to PC local hard drive. The files contain real time data from the converter modules 
that help in fault tracing and analysis. 

Note: The files can be uploaded from drive to local computer only. You cannot read the 
contents or open the files. For any further assistance contact ABB customer support.

 Uploading PSL2 data logger files

1. Go to Tools → PSL2 data logger. 

Figure 179. PSL2 Data logger
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2. Move the PSU data logger file(s) that you want to upload to the right side box. Use the 
right arrow (>>) or the left arrow (<<) button.

Figure 180. PSU datalogger file: select files

3. In the Upload directory field, click  and select an upload folder in your PC local 
hard drive.

4. Click Upload...

The selected files are transfered to your local folder.
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Using the PSL2 data viewer (pro)
You can open and view contents of the uploaded PSL2 data logger files in the PC local 
hard drive. The files contain real time data from the converter modules that help in fault 
tracing and analysis. 

 Viewing PSL2 data logger files

1. Go to Tools → PSL2 Data Viewer.

 PSL2 Data Viewer screen with PSL2 plotting tools appears. The plotting area is 
empty by default. See PSL2 Data Viewer instructions below to open and save the plot.

Figure 181. PSL2 Data viewer screen 

 PSL2 Data Viewer instructions

The PSL2 plotting tools can be used to plot current and DC voltage using the uff or csv file. 
The table below describes how to use the plotting tools. Match the below instructions with 
the above PSL2 Data viewer screen.

Action Instruction

Opening uff or csv file. In the PSL2 Data Viewer window, click Open file icon and 
select the file to open. 

Saving the plot as csv file. Click Save to CSV icon. 

Saving the plot into different file formats. Click Save plot icon.

Selecting number of channels to view in 
the plot.

Select number of channels in the Number of visible channels 
drop-down list.

Viewing the selected channels. See in Selected channel drop-down list..

Aligning selected channels on the same 
axis 

Click on Use only one axis check box. 
Use this option to draw all selected channels on the same axis.

Open file...
Save to CSV...

Save plot...
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Setting minimum and maximum values 
of X-axis and Y-axis

Set required minimum and maximum values in the below fields 
and click on Update axis button.
• Y-axis min

• Y-axis max

• X-axis min

• X-axis max

Note: The min/max values of X-axis and Y-axis are equal in all 
visible plots.

Scaling X-axis and Y-axis automatically Click on Auto Scale button.
The largest and smallest values of data are scaled to Y-max Y-
min respectively.
Note: This action does not maintain the same scale in every 
parallel axis. 

Resetting min/max values of Y-axis to 
default values

Click on Default Scale button.
The graph is reset to the updated default values.

Updating calculation parameters to plot 
and recalculate the data

Set current and voltage values in Curr meas range [A] and 
DC meas range [V]. Click on Update button.

Viewing different plots Click on the tabs to view the required plot:
• Total Current and DC SI

• Sum currents %

• Phase X current diff %

• Sum current filtered %

• DC voltage diff %

• Module currents % and DC %

Inside the plot you can also do the 
following actions using keypad and 
mouse:

• use the right mouse button to move (pan) the plot up/down. 
The x-/ y-axis moves accordingly.

• use the mouse wheel to zoom the plot. Zooming multiple 
channels works best when the cursor is placed on an empty 
space i.e. top of upper axis, below the lower axis, or between 
the axis. 

• mark a rectangle with Ctrl+Right mouse button or Ctrl+Left 
mouse button to zoom the marked area

• hold the Left mouse button to view the plot tracker

• press 'A' key to reset the axis to set values

• press Ctrl+C to copy the bitmap of plot.

Action Instruction
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Adaptive programming
Adaptive programming is a feature to control the operation of a drive by parameters. Each 
parameter has a fixed set of choices or a setting range. The parameters make 
programming easy, but the choices are limited. You cannot customize the operation 
further. 

The Adaptive programming makes easy customizing possible without the need of a 
special programming tool or language. The program is built of function blocks.

Figure 182. Adaptive programming

For further information on Adaptive programming, refer Adaptive programming application 
guide in List of related manuals.
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Locking user interface
A user interface lock function is implemented to notify the device lock states, for example, 
when parameter system is locked or when file downloading is disabled. 

The function prevents you from:
• uploading device data, when file download function is disabled or when parameter 

system is locked

• creating device backup when the device is in protected state.

The function is implemented in DCPT-01 and DCET-01. See below sections that describe 
the lock states visible in different pages or views in the Drive composer.

 Lock state in System info page

Go to the System info page by right clicking on the selected drive in the drive list and 
select System info. The different lock states displayed in the System info page are listed 
below. 

 Lock state in parameter view

The user interface lock states are displayed in the following parameters view:
• Parameters view for online drive (see page 72)

• Custom parameter view (see page 84)

• Offline parameter view (see page 88)

• File parameter view (see page 72)

In the parameters view, the device lock states, i.e. Parameter system is locked or the File 
downloading is disabled, are accessible when you mouse hover the below two buttons:

•  Save parameters to file

•  Download to device 

The table below lists the different device states displayed in the parameters view. The 
example screens are from the custom parameter view. 

Device lock state Lock state messages

Initial state Set button is enabled.

Parameter system is 
locked

Set button is disabled. When you mouse hover the button, the tooltip “Parameters 
are locked on drive” appears.

File download is 
disabled

Set button is disabled. When you mouse hover the button, the tooltip “File 
downloading is disabled on drive” appears.
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Note: The two buttons listed above may be hidden and may not be visible in all views. 
When data in the view is loaded for different drives, the drive which is connected may not 
show the correct state of the buttons until you change the drive.

 Lock state in Backup/Restore page

Go to the Backup/Restore page by right clicking on the selected drive in the drive list and 
select Backup/Restore. The different lock states displayed in the Backup/Restore page 
are listed below. 

Device lock state Lock state messages

Initial state Save parameters to file and Download to device buttons are enabled.

Parameter system is 
locked

Save parameters to file button is enabled. Download to device button is 
disabled. When you mouse hover the disabled button, the tooltip “Parameters are 
locked on drive” appears.

File download is 
disabled

Save parameters to file button is enabled. Download to device button is 
disabled. When you mouse hover the disabled button, the tooltip “File downloading 
is disabled on drive” appears.

Device lock state Lock state messages

Initial state All buttons, Backup, Restore and Advanced restore are enabled.

Note: Advanced restore button is available only in Drive composer pro, DCPT-01 
(code: 3AUA0000108087).

Parameter system is 
locked

Backup button is enabled. Restore and Advance restore buttons are disabled. 
When you mouse hover the disabled buttons, the tooltip “Parameters are locked on 
drive” appears.

Note: Advanced restore button is available only in Drive composer pro, DCPT-01 
(code: 3AUA0000108087).

Save parameters to file
Download to device
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 Lock state in Safety settings page (pro)

Go to the Safety settings page by right clicking on the selected drive in the drive list and 
select Safety settings. The different lock states displayed in the Safety settings page are 
listed below. 

Note: The lock state messages are visible only in Drive composer pro, DCPT-01 (code: 
3AUA0000108087).

File download is 
disabled

Backup button is enabled. Restore and Advance restore buttons are disabled. 
When you mouse hover the disabled buttons, the tooltip “File downloading is 
disabled on drive” appears.

Note: Advanced restore is available only in Drive composer pro, DCPT-01 (code: 
3AUA0000108087).

Device lock state Lock state messages

Initial state Buttons enabled: 

•  Read settings from drive 

•  Apply settings to drive

•  Print report

•  Reboot FSO

•  Change password.

Load from file is always enabled.

Save to file is enabled only when data is read.

Parameter system is 
locked

Buttons disabled:

•  Read settings from drive 

•  Apply settings to drive

•  Print report

•  Reboot FSO

•  Change password.

When you mouse hover the disabled buttons, the tooltip “Parameters are locked on 
drive” appears.

Load from file is always enabled.

Save to file is enabled only when data is read.

Device lock state Lock state messages
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 Lock state in Localization editor (pro)

Go to Tools → Localization Editor. Select the drive to work with and click Ok. The 
Localization editor screen appears.

The different lock states displayed in the Localization editor are listed below. 

Note: The lock state messages are visible only in Drive composer pro, DCPT-01 (code: 
3AUA0000108087).

File download is 
disabled

Buttons disabled:

• Read settings from drive 

• Apply settings to drive

• Print report

• Reboot FSO

• Change password.

When you mouse hover the disabled buttons, the tooltip “File downloading is 
disabled on drive” appears.

Load from file is always enabled.

Save to file is enabled only when data is read.

Device lock state Lock state messages

Initial state Read button is always enabled.

Apply button is enabled only when text is changed in the Localized text column.

Parameter system is 
locked

Read button is always enabled.

If you changed text in the Localized text column, the changes are not effective 
and the Apply button is disabled. When you mouse hover the disabled button, 
the tooltip “Parameters are locked on drive” appears.

File download is 
disabled

Read button is always enabled.

If you changed text in the Localized text column, the changes are not effective 
and the Apply button is disabled. When you mouse hover the disabled button, 
the tooltip “File downloading is disabled on drive” appears. 

Device lock state Lock state messages
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Annexure A: Creating DIB 
service report template

Contents of this chapter
This chapter describes the factors to consider when creating a service report template file 
for Drive Installed Base (DIB).
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Generic wizard step  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  183
Components . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  183

Common properties of components  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184
ComboBox properties of components . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184
DataGridView properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 185

DataBindings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  186
DataSource . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 186
DataTarget. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187

Saving the DC wizard template in StepDesigner . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  189
Deploying a template file  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  190
Localizing service report templates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  190



182   Annexure A: Creating DIB service report template
Creating a template for DIB service report (Internal use 
only)
Note: Service report templates are created by authorized ABB personnel only. It you need 
to create template, contact your local ABB representative.

You can create a template file for DIB service report using the Step Designer tool. You will 
need necessary permissions to access the tool. The tool has different steps (see page 
183) and components (see page 183), but not all of them are used in the DIB service 
reporting template. 

The project file (SDDIBTemplate.xml) is located in the DIB service portal. The file contains 
all currently supported components and databindings (see page 186). See descriptions in 
below sections.

The example screens show General Information for service actions.
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Generic wizard step
The Generic wizard step is used in the DIB template structure. Currently, the template 
supports only this step. 

The table below lists the sections and properties of the Generic wizard step used in the 
DIB service report.

Components
The table below lists the components used in DIB service reports.

Section Property Comment

Configuration Display Name (presented as 
“Title” in DIB service report)

Mandatory to fill this value.

Description Appears below “Title”

DC Wizard Printing AddToReport Determines that page is visible on print 
preview.

Component Presented as ...

CommentsControl multiline text component

NumericTextBox numeric component

Note: Accepts numeric values only.

CheckBox,

ThreeStateCheckBox

checkbox

TextBox,

BinaryTextBox,

StringTextBox,

HexTextBox

one-line text components

Filechooser user file selectable component

ComboBox drop-down list

DataGridView table
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 Common properties of components

The following properties are common for the components defined in DIB service report.

 ComboBox properties of components

You can use the following combo box property to define the components in DIB service 
report. 

Section Property Comment

Configuration DataBinding Defines data input and output of the component. See also 
DataBinding xx.

DefaultValue Defines default value of the component. This value is used if 
source databinding is not defined.

Display Name Appears as “Title” in service report. This is a mandatory 
value.

enabled (value) Defines that component is read-only

enabled (expression) Not supported

ValueRequired Defines if value must be filled. 

True = Value is required before navigating to the next page.
False = Value is not required

DC Wizard Printing AddToReport Determines the print preview of service report page.

BlankLineAfter Adds one empty line in print report after this component.

OmitIfEmpty Does not print the component if there is no value.

PageBreakAfter Adds page break in print report after this component.

Property Comment

PossibleValues (value) Shows values in the drop down list. Selecting a value opens a new editor. 
You can add, change or remove a value. See example screen below. 

In the new editor, you can define name and value of the property. Data in 
the Value field is sent to DIB service. Make sure that this data is 
synchronized with the expected data value.

PossibleValues (expression) Not supported
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 DataGridView properties

You can use the following data grid view property to define components in DIB service 
report. 

Property Comment

DCWizardColumns Defines columns in the table. Selecting a column value opens a new editor. You can 
add, change or remove a column value. See example screen below. 

In the new editor, you can define the column properties: 

Note: Columns defined are not visible in StepDesigner, but are visible only in DIB 
service report wizard.

Column property Comment

DataBinding Defines data input and output. See also DataBindings xx

Enabled Enables read-only column mode.

Name Defines column header text.

PossibleValue Defines possible values if column type is DropDown. 

Note: This property is not supported for other column 
types.

Type Defines following data types: String, Numeric, Date, 
CheckBox, DropDown

http://
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DataBindings
DataBindings define how to fill the component with data and to where the filled data must 
be sent. The DIB service report includes two types of DataBinding properties:
• DataSource

• DataTarget

You can fill the properties using existing DataBinding properties in the StepDesigner tool. 
See the sample format below:

"{DataSourceBinding}{DataTargetBinding}"

The format is converted to:

DataSource = "DataSourceBinding"

DataTarget = "DataTargetBinding"

If value in “DataBinding” does not match with the previous format, the value is assigned to

"DataSource" property and "DataTarget" remains empty.

 DataSource

DataSource is a DataBinding property that defines how component data must be filled if 
you started the service report wizard for the first time and default value was empty.

See the data source list supported by Drive composer PC tool:

Property Comment

DateTimeNow Defines current date

Par.G.I Drive parameter group and index. 

For example, Par.1.11, means that Drive composer reads value from parameter group 1 
and index 11 of the selected drive.

Info.ID System info ID number or drive info defined by ID.

For example, Info.1, means that Drive composer reads drive serial number.

UserEmail Email ID of user logged in to DIB service.

Drive Data object received from DIB service. For example,

Drive.SerialNumber–reads drive serial number

Drive.EndCustomer.Name–reads end customer name

Drive.Site.StreetAddress–reads site address where the drive is installed 
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 DataTarget

DataTarget is a DataBinding property that defines how to send value of current component 
to DIB service. Drive composer sends the value to multiple object types of DIB service. 

DataTarget objects

The table below list the objects created based on DataTarget definitions:

Component Drive components for table data. Each column has an appropriate component type 
property as its DataSource. See below example code:

<Components>

<Component c:type="CfrTable" id="DataGridView_1" 
dataBinding="{Component}{}">

<DCWizardColumns>

<Column name="Version" databinding="{Version}{}" type="String" 
enabled="tru

e" />

<Column name="Description" databinding="{}{Description}" 
type="String" enab

led="true" />

</DCWizardColumns>

</Component>

• Each row fills with a component property

• The column name Version reads data from Component.Version property

• The column name Description reads value from Component.Description property. 

Object Subtypes

DriveComposerServiceEvent ServiceEventWarrranty

ServiceEventFault

Collection of objects of ServiceEventReplacedPart type

ServiceEventSite

ServiceEventEndCustomer

ServiceEventFieldServiceEngineer

Collection of objects of MaterialCodeInstalled type

ServiceEventServiceProvider

OnSiteActivities

• Commissioning

• Collection of Fault type objects

• Collection of Attachment type objects

MaintainedComponent 
(collection of objects)

-

Property Comment
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DataTarget examples

The objects defined as collection, use the DataTarget in two ways:

Fault.Code–value from this component fills property Code in object type Fault. If you 
added more than one component, Drive composer sends only the value of first component 
in the page to DIB service.

Fault.Code|1...3–based on components with three different bindings three objects of Fault 
type are created. You can define more than one collection element on one page.

 

If DataTarget =... Value fills this property

DriveComposerServiceEvent.SerialNumber SerialNumber in object type DriveComposerServiceEvent

ServiceEventEndCustomer.Name Name in object type ServiceEventEndCustomer, which is 
defined as property EndCustomer in object type 
DriveComposerServiceEvent

ServiceEventWarranty.ResponsibleUnit ResponsibleUnit in object type ServiceEventWarranty, 
which is defined as property Warranty in object type 
DriveComposerServiceEvent
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Saving the DC wizard template in StepDesigner
After you designed a service report template with the StepDesigner tool using 
components, databindings, etc., save the template file to Drive composer reporting wizard 
format (.dcwiz) and set the file as custom printing template file format (.xaml). The custom 
printing template defines the common appearance of printed pages like header, footer, 
etc.

To save the template file, 

1. In StepDesigner, go to File → Save DC Wizard template.

Figure 183. Save DC Wizard template

The file is saved in .dcwiz format.

2. Click Yes, to set the file as custom printing template file (.xaml format) or click No, to 
use the default printing template.

Figure 184. Set custom printing template

Note: 
• The template must contain a ContentControl named "cc". 

• ABB recommends that you use the same name for both files for better identification.
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Deploying a template file
The Service reporting (create_service_report.html) module contains all service report 
template files. You can see a range of entries in the Select service type list. Each entry 
refers to a template file.

To deploy a template file,

1. Create a template structure in StepDesigner tool. See Creating a template for DIB 
service report (Internal use only) on page 182.

2. Save the file to StepDesigner format.

3. Create a .dcwiz file. See steps for Saving the DC wizard template in StepDesigner. 

ABB recommends that you use the same name for both files for better identification.

4. If you have multiple templates, repeat steps 1...3.

5. Create a zip file of the multiple files.

6. Upload the zip file to DIB service portal. If you do not have the necessary permissions, 
you can request the DIB team to upload the files.

Localizing service report templates
Consider the following points, 
• Whenever you change the language settings in Drive composer, see the localized 

templates list in service types of Service reporting (create_service_report.html) 
module.

• Language files are recognized by their file names. For example, 

• File.dcwiz or File_en.dcwiz refers to English template file.

• File_pl.dcwiz refers to Polish template file.

• File_fi.dcwiz refers to Finnish template file. 

• When you selected a language, all properties (Display Name, Description, Name, etc.) 
are translated to their respective languages.

• When you selected a language, the files matching that language selection are only 
visible. If a particular language file does not exist, then English version is displayed as 
default.

Example:

The below example cases show the list of files visible when you selected a language. The 
template file is a zip file of following files.
• File.dcwiz

• SecondFile.dcwiz

• ThirdFile_en.dcwiz

• File_fi.dcwiz

• FourthFile_fi.dcwiz

Case If language selected is... The Select service type dropdown lists the following files:

Case 1 English • File

• SecondFile

• ThirdFile_en
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Case 2 Finnish • File_fi

• SecondFile

• ThirdFile_en

• FourthFile_fi

Case If language selected is... The Select service type dropdown lists the following files:
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—
Further information

Product and service inquiries
Address any inquiries about the product to your local ABB representative, quoting the type 
designation and serial number of the unit in question. A listing of ABB sales, support and 
service contacts can be found by navigating to abb.com/searchchannels.

Product training
For information on ABB product training, navigate to new.abb.com/service/training.

Providing feedback on ABB Drives manuals
Your comments on our manuals are welcome. Navigate to 
new.abb.com/drives/manuals-feedback-form.

Document library on the Internet
You can find manuals and other product documents in PDF format on the Internet at 
abb.com/drives/documents.

http://www.new.abb.com/service/training
http://www.abb.com/searchchannels
http://www.new.abb.com/drives/manuals-feedback-form
http://www.abb.com/drives/documents
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